首页 > 股票公式 > 大智慧成本线和黄金比组合主图指标公式

大智慧成本线和黄金比组合主图指标公式

{成本线}
CYC1:COST(1),COLORFF66CC;
CYC5:COST(5),COLORFF00CC;
CYC13:COST(13),COLOR00CCCC;
CYC34:COST(34),COLOR00DEEE;
CYC55:COST(55),COLOR00ACCC,LINETHICK2;
CYC79:COST(79),COLORAACC22;
CYC95:COST(95),COLORGREEN;
MA7:MEMA(EMA(CLOSE,3),7),COLORFFFFFF;
PARTLINE(MA7 ,(MA7>REF(MA7,1))-1,rgb(0,255,0),1,rgb(255,0,0) ),LINETHICK3,LAYER0;
P:=BARSLAST(DISPSTATUS=1)+1;
{5.黄金比}
ah:=hhvall(hhv(h,P));
al:=llvall(llv(l,P));
nnl:=DISPSTATUS=2;
ahl:=ah-al;
q191:=al+ahl*0.191;
q382:=al+ahl*0.382;
q500:=al+ahl*0.500;
q618:=al+ahl*0.618;
q809:=al+ahl*0.809;
DRAWTEXT(nnl,ah,’ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄’),ALIGN1,COLOR0000ff;
DRAWTEXT(nnl,q809,’ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄’),ALIGN1,COLORddaa00;
DRAWTEXT(nnl,q618,’ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄’),ALIGN1,COLORddaa00;
DRAWTEXT(nnl,q500,’ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄’),ALIGN1,COLOR00ffff;
DRAWTEXT(nnl,q382,’ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄’),ALIGN1,COLORddaa00;
DRAWTEXT(nnl,q191,’ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄’),ALIGN1,COLORddaa00;
DRAWTEXT(nnl,al,’ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄’),ALIGN1,COLOR00ff00;
DRAWTEXT(nnl,ah*0.998,’最高.’+ah+”),ALIGN0,Color0047FF,LINETHICK1;
DRAWTEXT(nnl,q809,’80.9%.’ +q809+”),ALIGN0,Color00FFff,LINETHICK1;
DRAWTEXT(nnl,q618,’61.8%.’+q618+”),ALIGN0,Color0047FF,LINETHICK1;
DRAWTEXT(nnl,q500,’50%.’+q500+”),ALIGN0,Color00FFff,LINETHICK1;
DRAWTEXT(nnl,q382,’38.2%.’+q382+”),ALIGN0,Color0047FF,LINETHICK1;
DRAWTEXT(nnl,q191,’19.1%.’+q191+”),ALIGN0,Color00FFff,LINETHICK1;
DRAWTEXT(nnl,al*1.01,’最低.’+al+”),ALIGN0,VALIGN2,Color0047FF,LINETHICK1;

推荐阅读