首页 > 股票公式 > 大智慧牛熊持股主图指标公式

大智慧牛熊持股主图指标公式

VAR1:=(100 – ((90 * (HHV(HIGH,21) – CLOSE)) /
(HHV(HIGH,21) – LLV(LOW,21))));
VAR2:=(100 – ((90 * (HHV(HIGH,21) – CLOSE)) /
(HHV(HIGH,21) – LLV(LOW,21))));
VAR3:=(100 – MA(((100 * (HHV(HIGH,6) – CLOSE)) /
(HHV(HIGH,6) – LLV(LOW,6))),34));
DRAWICON(CROSS(VAR2,MA(VAR3,6)),(LOW * 0.97),8);
DRAWICON(CROSS(MA(VAR3,6),VAR1),(HIGH * 1.05),9);
DRAWTEXT(CROSS(VAR2,MA(VAR3,6)),(LOW * 0.97),’●买’),
colorGreen,linethick1;
DRAWTEXT(CROSS(MA(VAR3,6),VAR1),(HIGH * 1.05),’▼减仓’),
colorYellow,linethick1;
牛熊线:EMA(MA(CLOSE,3),34),COLORFF00FF,LINETHICK2;
STICKLINE(C>=牛熊线 AND C>=O,C,O,5,0),COLORRED;
STICKLINE(C>=牛熊线 AND C>=O,H,L,0,0),COLORRED;
STICKLINE(C>=牛熊线 AND C<O,C,O,5,1),COLORRED;
STICKLINE(C>=牛熊线 AND C<O,O,H,0,0),COLORRED;
STICKLINE(C>=牛熊线 AND C<O,C,L,0,0),COLORRED;
STICKLINE(C<牛熊线 AND C>O,C,O,5,1),COLORffff00;
STICKLINE(C<牛熊线 AND C<=O,C,O,5,1),COLORffff00;
STICKLINE(C<牛熊线 AND C<=O,H,L,0,1),COLORffff00;
STICKLINE(C<牛熊线 AND C>O,C,H,0,1),COLORffff00;
STICKLINE(C<牛熊线 AND C>O,O,L,0,1),COLORffff00;
TY:=C;
A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10);
C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10);
A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10);
C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);
A:=REF(C,BARSLAST(HD));
Z:=REF(L,BARSLAST(LD));
T1:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD) ;
T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);
波段头:IF(T1,A,A),COLORYELLOW,LINETHICK2,POINTDOT;
波段底:IF(T2,Z,Z),COLORWHITE,LINETHICK2,POINTDOT;

推荐阅读