1. 首页
  2. 股票公式

通达信抓涨停主图指标公式

通达信抓涨停主图指标公式

N:=30;M:=95;N1:=7;N2:=79;
V1:=EMA(CLOSE,5),COLORYELLOW;
V2:=EMA(EMA(CLOSE,29)*1.01,10),COLORFFCC66;
V3:=EMA(CLOSE,10),COLORFF00FF;
V4:=EMA(EMA(CLOSE,60)*0.99,10),COLOR0099FF;
VAR11:=AMOUNT/VOL/100;
运作:= MA(CLOSE,18),COLORWHITE;
平均:=EMA(EMA(VAR11,2),N),COLOR00FF00;
底仓:= EMA(EMA(VAR11,13),M),COLORBLUE;
无穷成本均线:=DMA(CLOSE,VOL/CAPITAL),COLORBLUE;
持仓:IF(CLOSE>=SAR(4,8,20),SAR(4,8,20)*0.96,DRAWNULL),CIRCLEDOT ,COLORRED ;
空仓:=IF(CLOSE<SAR(4,8,20),SAR(4,8,20),DRAWNULL),CIRCLEDOT ,COLORGREEN ;
量能饱和:(AMOUNT/CLOSE)/HHV((AMOUNT/CLOSE),26)*100,COLORRED,NODRAW;
换手率:VOL/CAPITAL*100,COLORGREEN,NODRAW;
大盘指数:=INDEXC,NODRAW,COLORLIMAGENTA ;
涨:INDEXADV,NODRAW,COLORLIMAGENTA ;
跌:INDEXDEC,NODRAW,COLORGREEN;
数浪(未来):ZIG(3,5),COLORWHITE,LINETHICK1;
VAR326:=IF(CLOSE>REF(CLOSE,1),88,0);
VAR327:=IF(CLOSE/REF(CLOSE,1)>1.050 AND HIGH/CLOSE<1.010 AND VAR326>0, 91, 0);
STICKLINE(VAR327>90,L*0.99,L*0.95,4,0),COLORYELLOW;
DRAWTEXT(VAR327>90,LOW*0.95,32),COLORYELLOW;
操作线:=EMA(C,7),COLOR00FF00;
A:=(REF(操作线,1));
STICKLINE((操作线>A),A,操作线*0.98,6,0),COLOR0000FF;
STICKLINE((操作线<=A),A,操作线*1.01,6,0), COLOR00FF00;
M9:=(MA(CLOSE,9));
Y:=((HIGH+LOW)/(2));
AO:=MA(Y,5)-(MA(Y,34));
DU0:=(CROSS(AO,0));
UD0:=(CROSS(0,AO));
TDU0:=(BARSLAST(DU0));
TUD0:=(BARSLAST(UD0));
DU3:=(REF(DU0,1));
UD3:=(REF(UD0,1));
TDU3:=(BARSLAST(DU3));
TUD3:=(BARSLAST(UD3));
UDGLINE:=(IF((TDU3<TUD3),REF(HHV(HIGH,2),TDU3),REF(LLV(LOW,2),TUD3)));
JDU0:=(REF(CLOSE,1)<=REF(UDGLINE,1)) AND (CLOSE>UDGLINE) AND (TDU0<(TUD0));
JUD0:=(REF(CLOSE,1)>=REF(UDGLINE,1)) AND (CLOSE<UDGLINE) AND (TUD0<(TDU0));
JDU1:=JDU0 AND (COUNT(JDU0,TDU0)=(1));
JUD1:=JUD0 AND (COUNT(JUD0,TUD0)=(1));
JDU2:=JDU1 AND (REF(BARSLAST(JUD1),1)<(REF(BARSLAST(JDU1),1)));
JUD2:=JUD1 AND (REF(BARSLAST(JUD1),1)>(REF(BARSLAST(JDU1),1)));
JDU3:=JDU1 AND (REF(BARSLAST(JUD1),1)>(REF(BARSLAST(JDU1),1)));
JUD3:=JUD1 AND (REF(BARSLAST(JUD1),1)<(REF(BARSLAST(JDU1),1)));
DRAWTEXT(JDU2,(M9)*(0.94999998),33),COLORYELLOW;
VAR1:=(((CLOSE-MA(CLOSE,30))/(MA(CLOSE,30)))*(100));
VAR2:=(CLOSE>OPEN) AND (OPEN-LOW>HIGH-(CLOSE));
VAR3:=(REF(VAR1,1)<(-20)) AND (VAR2);
VAR4:=(REF(VAR1,1)<(-20)) AND (CLOSE>OPEN) AND (((CLOSE-REF(CLOSE,1))/(REF(CLOSE,1)))*(1000)>(20));
VAR5:=(FILTER((VAR3 OR VAR4),3));
VAR6:=(OPEN>CLOSE) AND (HIGH-IF((CLOSE>OPEN),CLOSE,OPEN)>IF((OPEN<CLOSE),OPEN,CLOSE)-(LOW));
VAR7:=(REF(VAR1,1)>ABS((-20))) AND (VAR6);
VAR8:=(REF(VAR1,1)>ABS((-20))) AND (CLOSE<OPEN) AND (((REF(CLOSE,1)-CLOSE)/(REF(CLOSE,1)))*(1000)>(20));
VAR9:=(FILTER((VAR7 OR VAR8),3));
VAARA:=(REF(VAR1,1)<(-13)) AND (VAR2);
VARB:=(REF(VAR1,1)<(-13)) AND (CLOSE>OPEN) AND (((CLOSE-REF(CLOSE,1))/(REF(CLOSE,1)))*(1000)>(20));
VARC:=(FILTER((VAARA OR VARB),3));
VARD:=(REF(VAR1,1)>ABS((-13))) AND (VAR6);
VARE:=(REF(VAR1,1)>ABS((-13))) AND (CLOSE<OPEN) AND (((REF(CLOSE,1)-CLOSE)/(REF(CLOSE,1)))*(1000)>(20));
VARF:=(FILTER((VARD OR VARE),3));
DRAWTEXT(((VARF)*(VAR1)>0),(1)*(REF(CLOSE,1)),34),COLORGREEN;
M1:EMA(CLOSE,3),COLORWHITE;
M2:=EMA(CLOSE,8);
M3:EMA(M2,13),COLORGREEN;
VAR14:=EMA(M3,55);
VAR15:=(REF(HIGH,1)+REF(LOW,1))/2;
VAR16:=MA(CLOSE,20)+2*STD(CLOSE,20);
DRAWTEXT(CROSS(VAR15,VAR16),HIGH*1.06,35), COLORGREEN;
VAR17:=REF(CLOSE,1);
VAR18:=SMA(MAX(CLOSE-VAR17,0),N1,1)/SMA(ABS(CLOSE-VAR17),N1,1)*100;
VAR19:=CROSS(N2,VAR18);
VARA:=FILTER(VAR9,4);
DRAWTEXT(VARA,HIGH*1.06,36), COLORGREEN;
_红柱:=IF(“MACD.MACD”>REF(“MACD.MACD”,1),”MACD.MACD”,DRAWNULL),STICK,COLORRED;
绿柱:=IF(“MACD.MACD”<REF(“MACD.MACD”,1),”MACD.MACD”,DRAWNULL),
STICK,COLORGREEN;
_抄底:=ABS((CROSS(“MACD.DIF”,”MACD.DEA”)
&&”MACD.DEA”<=-0.07)*”MACD.DIF”)*1.50,COLORLIMAGENTA;
_DIF:=”MACD.DIF”,COLORWHITE;
_DEA:=”MACD.DEA”,COLORYELLOW;
__强度:=IF(_DIF>_DEA,_DIF,DRAWNULL),COLORRED,LINETHICK2;
_强度:=IF(_DEA<_DIF,_DEA,DRAWNULL),COLORMAGENTA,LINETHICK2;
DRAWTEXT(ABS(_抄底)>0,LOW*0.98,37),COLORMAGENTA;

原创文章,作者:股神,如若转载,请注明出处:http://www.gupiaoxuexi.com/post/19285

发表评论

登录后才能评论