1. 首页
  2. 股票公式

通达信量价合一MACD指标公式

通达信量价合一MACD指标公式

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2,COLORSTICK;
DIFL:=EMA(VOL,12)-EMA(VOL,26);
DEAL:=EMA(DIFL,9);
MACL:=(DIFL-DEAL)*2,COLORSTICK;
基点:=CONST(LLV(MACL,250)); 基:=CONST(HHV(MACL,250))-基点;
STICKLINE(MACL>=0,0,MACL,2,-1),COLORLIRED;
STICKLINE(MACL<=0,0,MACL,2,-1),COLORLIBLUE;
分:=CONST(LLV(MACD,250)); 百:=CONST(HHV(MACD,250))-分;
C比:=(MACD-分)/百;
价柱:C比*基+基点,COLORSTICK;
DIF1:DIFL,COLORGREEN;
DEA1:DEAL,COLORMAGENTA;
分1:=CONST(LLV(DIF,250)); 百1:=CONST(HHV(DIF,250))-分1;
C比1:=(DIF-分1)/百1;
价F:C比1*基+基点,COLORWHITE,LINETHICK1;
分2:=CONST(LLV(DEA,250)); 百2:=CONST(HHV(DEA,250))-分2;
C比2:=(DEA-分2)/百2;
价A:C比2*基+基点,COLORYELLOW,LINETHICK1;

原创文章,作者:股神,如若转载,请注明出处:http://www.gupiaoxuexi.com/post/23432

发表评论

登录后才能评论