首页 > 股票公式 > 通达信超赢短线主图指标公式

通达信超赢短线主图指标公式

ZGD:=HHV(H,210)*0.99;
ZGD2:=CONST(ZGD);
ZDD:=LLV(L,210);
ZDD2:=CONST(ZDD);
急速超跌:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<-14;
VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);
红色持股:VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,NODRAW,COLOR0000FF;
青色观望:VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,NODRAW,COLORFFFF00;
黄底短买:VAR19,NODRAW,COLOR33FFCC;
品红离场:VAR1A,NODRAW,COLORFF00FF;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),2.8,0),COLOR33AACC;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),2.6,0),COLOR33AACC;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),2.4,0),COLOR33BBCC;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),2,2),COLOR33CCCC;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),2.0,0),COLOR33DDCC;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),1.8,0),COLOR33EECC;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),1.5,0),COLOR33FFCC;
DRAWTEXT(VAR19,REF(CLOSE,1),’←短买’),COLOR33FFCC;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2.8,0),COLORFF33FF;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2.3,0),COLORFF44FF;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2,0),COLORFF55FF;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),1.8,0),COLORFF66FF;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),1.5,0),COLORFF77FF;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),1.3,0),COLORFF88FF;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),1,0),COLORFF99FF;
DRAWTEXT(VAR1A,REF(CLOSE,1)+0.1,’←离场’),COLORFF99FF;

推荐阅读