首页 > 股票公式 > 通达信挣了钱的主图指标公式

通达信挣了钱的主图指标公式

ZF:=100*(C-REF(C,1))/REF(C,1);
STICKLINE((ZF>3.5 AND ZF<=5),O,C,1,0),COLORYELLOW;
STICKLINE((ZF>5),O,C,1,0),COLORRED;
M1:MA(C,5),COLORGREEN;
M2:MA(M1,5),COLORGREEN;
M3:MA(M2,5),COLORGREEN;
M4:MA(M3,5),COLORGREEN;
M5:MA(M4,5),COLORGREEN;
M1S:IF(M1>REF(M1,1),M1,DRAWNULL),COLORMAGENTA;
M2S:IF(M2>REF(M2,1),M2,DRAWNULL),COLORWHITE;
M3S:IF(M3>REF(M3,1),M3,DRAWNULL),COLORWHITE;
M4S:IF(M4>REF(M4,1),M4,DRAWNULL),COLORWHITE;
M5S:IF(M5>REF(M5,1),M5,DRAWNULL),COLORWHITE;
N:=1;
XOPEN:=(REF(O,N)+REF(C,N))/2;
XCLOSE:=CLOSE;
XHIGH:=MAX(HIGH,XOPEN);
XLOW:=MIN(LOW,XOPEN);
VOLALITY:=MA(XHIGH-XLOW,8);
凰线:=MA(XCLOSE,5)+VOLALITY/2;
凤线:=MA(XCLOSE,5)-VOLALITY/2;
BU:=CROSS(XCLOSE,凰线);
SEL:=CROSS(凤线,XCLOSE);
VAR1:=BARSLAST(BU);
VAR2:=BARSLAST(SEL);
DRAWICON(REF(VAR1,1)>VAR2 AND VAR1=0,XLOW,1);
TT2:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4.15),0.9);
TT1:=REF(EMA(TT2,3),1);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE – LC),0),3,1) / SMA(ABS((CLOSE – LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
AA1:=AMOUNT/VOL;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=VOL<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
F:=100*(C-REF(C,1))/REF(C,1);
P1:=IF(C<REF(O,1) AND F<0,1,0);
P2:=IF(C<REF(O,2) AND F<0,1,0);
TT3:=P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1 ;
TT4:=P1=1 AND REF(P1,1)=0 AND P2=1 AND REF(P2,1)=0 ;
Z1:=MA(C,13);
ZX:=REF(Z1,13/2+1);
A1:=EMA(C,14)COLORWHITE,LINETHICK1;
A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW;
出击:IF(A1X>=0,REF(EMA(C,14),BARSLAST(CROSS(A1X,0))+1),DRAWNULL)COLORRED,LINETHICK1;
{休假:IF(A1X<0,REF(EMA(C,14),BARSLAST(CROSS(0,A1X))+1),DRAWNULL)COLORGREEN,LINETHICK1;}
DRAWTEXT_FIX(C>0,0.004,1,0,DYBLOCK),COLORYELLOW,LINETHICK2;
DRAWTEXT_FIX(C>0,0.06,1,0,HYBLOCK),COLORRED,LINETHICK2;
DRAWTEXT_FIX(C>0,0.12,1,0,EXTERNSTR(0,1)),COLORWHITE,LINETHICK2;

推荐阅读