1. 首页
  2. 股票公式

通达信止赢止损分时主图指标公式

通达信止赢止损分时主图指标公式

MA1:=EMA(C,30);
MA2:=EMA(C,900);
STICKLINE((MA1>MA2),MA1,MA2,0,0),COLOR1000FF;
STICKLINE((MA1<MA2),MA1,MA2,0,0),COLOR00FF00;
GJ:C,COLORWHITE;
JJ:SUM(C*V,FROMOPEN)/SUM(V,FROMOPEN),COLORYELLOW,LINETHICK1.5;
均量:=MA(V,5);
量连增:=均量>REF(均量,1) AND REF(均量,1)>REF(均量,2);
价连涨:=C>=REF(C,1) AND REF(C,1)>REF(C,2);
价量线上:=C>JJ AND V>均量;
倍量:=V>=REF(V,1)*2 ;
价新高:=C>=HHV(C,FROMOPEN);
量新高:=V>=HHV(V,FROMOPEN);
限幅:=C/DYNAINFO(3)<=1.02;
起爆:=FILTER(量连增 AND 价连涨 AND 价量线上 AND 倍量 AND 价新高 AND 量新高 AND 限幅,20);
DRAWTEXT(起爆,C,’起爆’),COLOR00FFFF;
DRAWICON(起爆,C,1);
STICKLINE(起爆,C,JJ,1,0),COLOR1000FF;
VV:=BARSSINCE(起爆);
起爆价:=REF(C,VV);
起爆时间:=REF(TIME/10000,VV);
收益:=(DYNAINFO(7)-起爆价)/起爆价*100;
DRAWICON(VV>=2,起爆价,13);
DRAWTEXT_FIX(1,0,1,0,’起爆时间:’),COLOR00FFFF;
DRAWNUMBER_FIX(1,0.06,1,0,CONST(起爆时间)),COLOR00FFFF;
DRAWTEXT_FIX(1,0.12,1,0,’起爆价:’),COLOR00FFFF;
DRAWNUMBER_FIX(1,0.17,1,0,CONST(起爆价)),COLOR00FFFF;
DRAWTEXT_FIX(1,0.24,1,0,’收益:’),COLOR00FFFF;
DRAWNUMBER_FIX(1,0.28.06,1,0,CONST(收益)),COLOR00FFFF;
流通盘:CAPITAL*100/100000000,NODRAW;
资金流入:=SUM(IF(C>REF(C,1),V,0),FROMOPEN),NODRAW;
资金流出:=-SUM(IF(C<REF(C,1),V,0),FROMOPEN),NODRAW;
资金出入:=资金流入+资金流出,NODRAW;
NN:=2400,NODRAW;
HD:=HHV(资金出入,NN),NODRAW;
LD:=LLV(资金出入,NN),NODRAW;
最高:=CONST(HD),NODRAW;
最低:=CONST(LD),NODRAW;
HLMAX:=最高;
HLMIN:=最低;
HLMN1:=(HLMAX+HLMIN)/2;
HLMN2:=HLMAX-HLMIN;
HLMN3:=(100-0)/2*1.3;
HLMN4:=(100-0)/1*1.3;
中间价轴:=(50-HLMN3)*HLMN2/HLMN4+HLMN1;
轴差:=最高-最低;
DRAWBAND(资金出入,RGB(150,0,150),0,RGB(0,100,0)),NODRAW;
资金流量:资金出入,NODRAW;
资金比:资金出入/SUM(V,FROMOPEN)*100,NODRAW;
资金流量比:=IF(资金比>=0,(资金比+100)/2,100-ABS((资金比-100)/2)),NODRAW;
攻击量:=((HSL*0.50+REF(HSL,1)*0.33)+(REF(HSL,2)*0.17))*SUM(C,FROMOPEN)/FROMOPEN,NODRAW;
攻击量A:=SUM(IF(C>REF(C,1),攻击量*V,0),FROMOPEN),NODRAW;
攻击量B:=-SUM(IF(C<REF(C,1),攻击量*V,0),FROMOPEN),NODRAW;
攻击流量:攻击量A+攻击量B,NODRAW;
NOTEXT攻击线:攻击流量,NODRAW;
攻击比:攻击流量/SUM(V,FROMOPEN)*100,COLORRED,NODRAW;
资金攻击度:=IF(攻击比>=0,(攻击比+50),100-ABS((攻击比-50)));
{STICKLINE(资金流量A>0,资金流量A,0,1,0),COLOR0000FF;
STICKLINE(资金流量B<0,资金流量B,0,1,0),COLORFF0000;}
DRAWRECTREL(110,10,400,90,RGB(0,75,200));
DRAWRECTREL(110,10,250,90,RGB(0,250,50));
DRAWRECTREL(110,10,100+CONST(资金流量比*300/100),90,RGB(200,50,0));
DRAWTEXT_FIX(1,0.000,0.00,0,STRCAT(STRCAT(‘【资金流量比】’,CON2STR(资金流量比,2)),’%买’)),COLORYELLOW;
DRAWRECTREL(610,10,900,90,RGB(0,75,200));
DRAWRECTREL(610,10,750,90,RGB(0,250,50));
DRAWRECTREL(610,10,600+CONST(资金攻击度*300/100),90,RGB(175,50,0));
DRAWTEXT_FIX(1,0.500,0.00,0,STRCAT(STRCAT(‘【资金攻击度】’,CON2STR(资金攻击度,2)),’ %买’)),COLORYELLOW;
MA30:=EMA(CLOSE,30);
强弱:EMA(CLOSE,900);
STICKLINE((MA30>强弱),MA30,强弱,1,0),COLOR0000FF;
STICKLINE((MA30<强弱),MA30,强弱,1,0),COLOR00FF00;
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:L1+P1*7/8,COLOR00DD00;
支撑:L1+P1*0.5/8,COLOR00DD00;
现价:CLOSE,COLORWHITE,LINETHICK1;
STICKLINE(CROSS(支撑,现价),支撑,阻力,1,0),COLORYELLOW;
DRAWTEXT(LONGCROSS(支撑,现价,2),支撑*1.001,’★B吸’),COLORWHITE;{吸}
DRAWTEXT(LONGCROSS(现价,阻力,2),现价,’★S抛’),COLORGREEN;{抛};
{T+1止赢、止损}
止赢:H1,COLORRED,LINETHICK6;
DRAWTEXT(ISLASTBAR,H1,’当日止赢价位’),COLORRED,LINETHICK6;
止损:阻力,COLORBLUE,LINETHICK6;
DRAWTEXT(ISLASTBAR,阻力,’高位止损价位’),COLORBLUE,LINETHICK6;
最后止损:支撑,COLORGREEN,LINETHICK6;
DRAWTEXT(ISLASTBAR,支撑,’低位止损价位’),COLORGREEN,LINETHICK6;
UR:=10;LR:=10;
均价:SUM(V*C,0)/SUM(V,0),COLORYELLOW;

原创文章,作者:股神,如若转载,请注明出处:http://www.gupiaoxuexi.com/post/23653

发表评论

登录后才能评论