首页 > 股票公式 > 通达信牛犇主图指标公式

通达信牛犇主图指标公式

用法: 一;蓝线为两点同价线,在同价线出现时可以考虑买进; 二:快线上穿前低时可以考虑买进; 三:股价上穿前低买进; 四:股价上穿前高时买进; 五:以上四条都要配合量能; 六:量柱必须上穿3天量线和46天量线;

快线:MA(CLOSE,3);
慢线:MA(CLOSE,46);
M30:=MA(C,30);
M60:=MA(C,60);
VA1:=HHVBARS(M30,BARSLAST(M30<M60)+1);
VA2:=CROSS(BACKSET(CROSS(M60,M30),REF(VA1,1)+2),0.5);
QG:=CROSS(BACKSET(CROSS(0,M30) OR (ISLASTBAR AND M30>M60),REF(VA1,1)+2),0.5);
STICKLINE(M30>DRAWLINE(VA2,M30,REF(VA2,1),REF(M30,1),1),M30,DRAWLINE(VA2,M30,REF(VA2,1),REF(M30,1),1),1,0),COLOR00BBBB;
前高:DRAWLINE(VA2,M30,REF(VA2,1),REF(M30,1),1),COLORGREEN,DOTLINE;
JC:=CROSS(M30,M60);
JTS:=BARSLAST(JC);
XG1:=JTS>=0 AND M30>前高;
SC:=CROSS(M60,M30);
STS:=BARSLAST(SC);
XG2:=C<REF(LLV(M30,STS),JTS+1);
VA3:=LLVBARS(M30,BARSLAST(M30>M60)+1);
VA4:=CROSS(BACKSET(CROSS(M30,M60),REF(VA3,1)+2),0.5);
BD:=BARSLAST(FILTERX(CROSS(M60,M30),BARSCOUNT(C)));
BG:=BARSLAST(FILTERX(CROSS(M30,M60),BARSCOUNT(C)));
STICKLINE(M30<REF(LLV(M30,STS),JTS+1) AND M30<=M60,M30,REF(LLV(M30,STS),JTS+1),1,0),COLORGRAY;
前低:DRAWLINE(VA4,M30,REF(VA4,1),REF(M30,1),1),COLORMAGENTA,DOTLINE;
STICKLINE(XG1 AND H<前低,H*1.002,L*0.998,4,1),COLORWHITE;
STICKLINE(XG1 AND H>前低 AND MAX(C,O)<前低,前低,L*0.998,4,1),COLORWHITE;
STICKLINE(XG1 AND C<前低 AND O>前低,C*0.998,前低,4,1),COLORWHITE;
YDD:=L=REFX(L,1) OR L=REFX(L,2) OR L=REFX(L,3) OR L=REFX(L,4) OR L=REFX(L,5) OR L=REFX(L,6) OR L=REFX(L,7) OR L=REFX(L,8) OR L=REFX(L,9) OR L=REFX(L,10) OR L=REFX(L,11) OR L=REFX(L,12) OR L=REFX(L,13) OR
L=REFX(L,14) OR L=REFX(L,15) OR L=REFX(L,16) OR L=REFX(L,17) OR L=REFX(L,18) OR L=REFX(L,19) OR L=REFX(L,20);
EDD:=BARSLAST(YDD)>0 AND L=REF(L,BARSLAST(YDD));
两点同价:DRAWLINE(YDD AND CURRBARSCOUNT<120,L,EDD AND CURRBARSCOUNT<120,L,1)COLORBLUE;

推荐阅读