首页 > 股票公式 > 通达信第N次突破指标公式

通达信第N次突破指标公式

ZMA1:=(COST(99)+COST(93)+COST(85))/3;
ZMA2:=EXIST(CLOSE>ZMA1,10);
ZMA3:=CROSS(C,ZMA1);
ZMA4:=BARSLAST(ZMA3);
PW2:=REF(ZMA4,ZMA4+1)+ZMA4+1;{倒数第2个}
XG:IF(ZMA2,PW2-ZMA4,DRAWNULL),NODRAW;
ZIG挑头:ZIG(3,10)>REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<REF(ZIG(3,10),3);{今日ZIG大于昨天,昨日ZIG小于前日ZIG 数值)=ZIG挑头}
{为了避免信号飘逸 把时间拉长 REF(ZIG(3,10),1)>REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<REF(ZIG(3,10),3); 多了一天的时间确认点信号失败的可能性就降低了一些
如果还是出现失败信号,那买入的理由ZIG 的反转点啊,这样的话,止损的话 估计也会在5%左右。}
VAR11:=0-((100)*(HHV(HIGH,3)-CLOSE))/(HHV(HIGH,3)-LLV(LOW,3));
吃涨停:(VAR11=0) AND ((HHV(HIGH,3))/(LLV(LOW,3))>1+(15)/(100)) AND ((HHV(HIGH,3))/(LLV(LOW,3))<1+(25)/(100));
A1:=REF(C,1)/REF(C,2)>1.095;
A2:=C>O AND L/REF(C,1)>1.03;
A3:=A1 AND A2;
A4:=BARSSINCEN(A3,40);
A5:=A4=1 AND H>REF(HHV(H,40),38);
XG9:BARSSINCEN(A5,40)>30 AND CROSS(C,REF(HHV(H,40),5));
{今天涨幅大于3%、今天涨幅小于%8 股本小于2亿};
线5:=EMA(C,5);
工作线14:=EMA(C,14);
二号线25:=EMA(C,25);
M181:=MA(C,181);
S1:=IF(CODELIKE(‘300’),0,1);
{创业板 }
S2:=IF(NAMELIKE(‘S’),0,1);
S3:=IF(NAMELIKE(‘*’),0,1);
{去掉停牌 >=}
S4:=DYNAINFO(17)>0;
A6:=V>REF(V,20)*1.55 ;{成交量(手)>5日前的成交量(手)*2}
{股价N天内连续沿着5天线走,且每天收盘价与5天线的距离不超过2%}
沿着5天线走:=ABS(C-MA(C,5))/MA(C,5)<0.02;
去掉:=S1 AND S2 AND S3 AND S4 ;
倾角5日:=(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926)>45;
沿5天线:去掉 AND C/REF(C,1)>=1.03 && C/REF(C,1)<=1.097 AND A6 AND 倾角5日
AND CAPITAL/1000000<10 AND C<15 AND COUNT(沿着5天线走,6)=2
&& 线5>=工作线14 && 工作线14>=二号线25;
VAR1:=((LLV(LOW,5) = LLV(LOW,45)) AND (CLOSE >= (OPEN * 1.04)));
VAR2:=(CLOSE > ((REF(HIGH,1) + REF(LOW,1)) / 2));
VAR3:=REF(CLOSE,1);
VAR4:=((SMA(MAX((CLOSE – VAR3),0),6,1) / SMA(ABS((CLOSE – VAR3)),6,1)) * 100);
土狗潇洒:(VAR1 AND VAR2),STICK,COLORYELLOW,LINETHICK2;
潇洒土狗:CROSS(80,VAR4),STICK,COLORGREEN,LINETHICK2;
DRAWICON(土狗潇洒,0,23);
DRAWICON(潇洒土狗,1.5,2);
{横盘突破}
HA1:=HHVBARS(C,10);
HB1:=REF(HHVBARS(C,10),1);
横盘突破:IF(HA1=0 && HB1>5 , 1,0),COLORBLUE;
UA:=C>O;
UB:=REF(C,1)<REF(O,1);
阳线天数:COUNT(UA,20),NODRAW;
连阳天数:IF(UA,BARSLAST(UB)+1,0),NODRAW;
顶底距离:HHV(C,20)/LLV(C,20),NODRAW;

推荐阅读