首页 > 股票公式 > 通达信开涨信号选股指标公式

通达信开涨信号选股指标公式

MA1:=MA(C,5);
AA:=MA1*0.98;
BB:=REF(MA1,1)*0.98;
MM:=BARSLAST(REF(C,1)>=REF(MA1,1) AND C<MA1)+1;
NN:=BARSLAST(REF(C,1)>=REF(MA1,1) AND C<MA1);
QQ:=IF((REF(C,1)>=REF(MA1,1)) AND (C<MA1),
IF(REF(MA1,1)<MA1,AA,BB),IF(BARSSINCE(REF(C,1)>=REF(MA1,1)
AND C<MA1)>0,IF(REF(MA1, MM)< REF(MA1,NN),REF(MA1,NN)*0.98,
REF(MA1,MM)*0.98), REF(MA1,1)));
MA5:=MA(C,5);
A51:= REF(MA5,1)*0.98;
A52:= REF(MA5,2)*0.98;
B52:= BARSLAST(REF(C,2)>=REF(MA5,2) AND REF(C,1)<REF(MA5,1))+2;
B51:= BARSLAST(REF(C,2)>=REF(MA5,2) AND REF(C,1)<REF(MA5,1))+1;
DZ:=IF((REF(C,2)>=REF(MA5,2)) AND (REF(C,1)<REF(MA5,1)),
IF(REF(MA5,2)<REF(MA5,1),A51,A52),IF(BARSSINCE(REF(C,2)>=REF(MA5,2)
AND REF(C,1)<REF(MA5,1))>0,IF(REF(MA5, B52)< REF(MA5, B51),
REF(MA5,B51)*0.98, REF(MA5,B52)*0.98), REF(MA5,1)));
开涨:CLOSE>REF(QQ,1) AND REF(QQ,2)>REF(DZ,2);

推荐阅读