首页 > 股票公式 > 通达信准确率高得一比指标公式

通达信准确率高得一比指标公式

N:=9;
M1:=3;
M2:=3;
金波:=EMA((3)*(MA(CLOSE,3)) – (2)*(MA(CLOSE,6)),1),COLOR0000FF,LINETHICK1;
TIAOJIAN1:=C=HHV(C,60);
DAYS11:=BARSLAST(TIAOJIAN1);
跌50﹪:=L<REF(C,DAYS11)/1.64;
跌60:CURRBARSCOUNT<=10 AND L<REF(C,DAYS11)/1.68
AND 金波<H AND O>C AND REF(O,1)>=REF(C,1);
P:=21;
WH1:=IF(L=LLV(L,P),L,DRAWNULL);
WH2:=CONST(BARSLAST(WH1!=DRAWNULL));
WH3:=CONST(IF(WH2=0,H,REF(H,WH2)));
WH4:=CONST(REF(BARSLAST(H>WH3),WH2+1)+WH2+1);
WH5:=CONST(IF(WH4=0,H,REF(H,WH4)));
WH6:=CONST(REF(BARSLAST(H>WH5),WH4+1)+WH4+1);
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
0,COLOR9000F5;
K:SMA(RSV,M1,1),COLORWHITE;
D:SMA(K,M2,1),COLORYELLOW;
J:3*K-2*D,COLORGREEN;
A1:=BARSLAST(REF(CROSS(J,0),1));
底背离:=REF(CLOSE,A1+1)>CLOSE AND J>REF(J,A1+1) AND CROSS(J,0);
J背离上穿0买: IF(底背离 AND LLV(J,7)>LLV(J,30),100,0),COLORRED,LINETHICK2;
DRAWTEXT(底背离,J-25,底背离),COLOR9000F5;
进场:IF(CURRBARSCOUNT<=WH2+21,CONST(IF(WH6=0,H,REF(H,WH6))),DRAWNULL),COLORRED;
IF(CURRBARSCOUNT<=WH2+1,IF(L=LLV(L,P),L,DRAWNULL),DRAWNULL),CIRCLEDOT,COLORRED;
DRAWTEXT(CURRBARSCOUNT=INTPART((WH2+21)*0.618),进场,’进场线’),COLORRED;
超跌进场:IF(CURRBARSCOUNT<=WH2+21,CONST(IF(WH4=0,H,REF(H,WH4))),DRAWNULL),COLORCB21BE;
DRAWTEXT(CURRBARSCOUNT=INTPART((WH2+21)*0.618),’超跌进场’,’超跌进场线’),COLORCB21BE;
H1:=IF(H=HHV(H,P),H,DRAWNULL);
H2:=CONST(BARSLAST(H1!=DRAWNULL));
H3:=CONST(IF(H2=0,L,REF(L,H2)));
H4:=CONST(REF(BARSLAST(L<H3),H2+1)+H2+1);
H5:=CONST(IF(H4=0,L,REF(L,H4)));
H6:=CONST(REF(BARSLAST(L<H5),H4+1)+H4+1);
止损:IF(CURRBARSCOUNT<=H2+21,CONST(IF(H6=0,L,REF(L,H6))),DRAWNULL) AND J背离上穿0买 AND 跌60,COLORYELLOW;
IF(CURRBARSCOUNT<=H2+1,IF(H=HHV(H,P),H,DRAWNULL),DRAWNULL),CIRCLEDOT,COLORBLUE;
DRAWTEXT(CURRBARSCOUNT=INTPART((H2+21)*0.618),’止损’,’止损线’),COLORYELLOW;

推荐阅读