1. 首页
  2. 股票公式

通达信拉升黑马主图及选股指标公式

通达信拉升黑马主图及选股指标公式

A6:=EMA(CLOSE,5),COLORGREEN;
A10:=EMA(CLOSE,10),COLORGREEN;
RJ:=(C+O)*1/2;
JJJ:=IF(DYNAINFO(8)>0.01,0.01*DYNAINFO(10)/DYNAINFO(8),DYNAINFO(3));
DDD:=(DYNAINFO(5)<0.01 || DYNAINFO(6)<0.01);
JJJT:=IF(DDD,1,(JJJ<(DYNAINFO(5)+0.01) && JJJ>(DYNAINFO(6)-0.01)));
CYC1:=IF(JJJT,0.01*EXPMA(AMOUNT,6)/EXPMA(VOL,6),EMA((HIGH+LOW+CLOSE)/3,6)),COLORGREEN;
CYC2:=IF(JJJT,0.01*EXPMA(AMOUNT,8)/EXPMA(VOL,8),EMA((HIGH+LOW+CLOSE)/3,8)),COLORGREEN;
CYC3:=IF(JJJT,0.01*EXPMA(AMOUNT,34)/EXPMA(VOL,34),EMA((HIGH+LOW+CLOSE)/3,34));
CYC∞:=IF(JJJT,DMA(AMOUNT/(100*VOL),100*VOL/FINANCE(7)),EMA((HIGH+LOW+CLOSE)/3,120));
B:=CROSS(CYC1>REF(CYC1,1) AND CYC2>REF(CYC2,1) AND CYC3>REF(CYC3,1)AND CYC∞>REF(CYC∞,1) AND C>CYC∞ AND RJ>REF(RJ,1) AND A6>REF(A6,1),0.2);
拉升进入:= CROSS(C,CYC∞) AND CYC∞>REF(CYC∞,1) AND CYC1>REF(CYC1,1) AND CYC2>REF(CYC2,1) AND CYC3>REF(CYC3,1);
MA1:MA(CLOSE,5);
MA2:MA(CLOSE,10);
MA3:MA(CLOSE,20);
MA4:MA(CLOSE,30);
DRAWTEXT(B,LOW-(H-L)*0.6,’升’),COLORRED;
DRAWTEXT(拉升进入,LOW-(H-L)*0.96,’拉升’),COLORRED;

{
选股公式:

A6:=EMA(CLOSE,5),COLORGREEN;
A10:=EMA(CLOSE,10),COLORGREEN;
RJ:=(C+O)*1/2;
Q1:=IF(C>A6,A6,DRAWNULL),COLORWHITE,LINETHICK2;
Q2:=IF(C>A10,A10,DRAWNULL),COLORRED,LINETHICK2;
JJJ:=IF(DYNAINFO(8)>0.01,0.01*DYNAINFO(10)/DYNAINFO(8),DYNAINFO(3));
DDD:=(DYNAINFO(5)<0.01 || DYNAINFO(6)<0.01);
JJJT:=IF(DDD,1,(JJJ<(DYNAINFO(5)+0.01) && JJJ>(DYNAINFO(6)-0.01)));
CYC1:=IF(JJJT,0.01*EXPMA(AMOUNT,6)/EXPMA(VOL,6),EMA((HIGH+LOW+CLOSE)/3,6)),COLORGREEN;
CYC2:=IF(JJJT,0.01*EXPMA(AMOUNT,8)/EXPMA(VOL,8),EMA((HIGH+LOW+CLOSE)/3,8)),COLORGREEN;
CYC3:=IF(JJJT,0.01*EXPMA(AMOUNT,34)/EXPMA(VOL,34),EMA((HIGH+LOW+CLOSE)/3,34));
CYC∞:=IF(JJJT,DMA(AMOUNT/(100*VOL),100*VOL/FINANCE(7)),EMA((HIGH+LOW+CLOSE)/3,120));
P1:=IF(CYC1>REF(CYC1,1) OR C>CYC1,CYC1,DRAWNULL),COLORWHITE,LINETHICK2;
P2:=IF(C>CYC2,CYC2,DRAWNULL),COLORRED,LINETHICK2;
B:=CROSS(CYC1>REF(CYC1,1) AND CYC2>REF(CYC2,1) AND CYC3>REF(CYC3,1)
AND CYC∞>REF(CYC∞,1) AND C>CYC∞ AND RJ>REF(RJ,1) AND A6>REF(A6,1),0.2);
拉升进入:= CROSS(C,CYC∞) AND CYC∞>REF(CYC∞,1) AND CYC1>REF(CYC1,1) AND CYC2>REF(CYC2,1) AND CYC3>REF(CYC3,1);
FILTER(拉升进入,5),COLORYELLOW;
}

原创文章,作者:股神,如若转载,请注明出处:http://www.gupiaoxuexi.com/post/26916

发表评论

登录后才能评论