1. 首页
  2. 股票公式

通达信黄金通道主图指标公式

通达信黄金通道主图指标公式

N2:=5;
A1:=REF(H,N2)=HHV(H,2*N2+1);
B1:=FILTER(A1,N2);
C1:=BACKSET(B1,N2+1);
HD:= FILTER(C1,N2);
RH:=BACKSET(CURRBARSCOUNT=2,BARSLAST(HD)+1);
SH:=RH>REF(RH,1);
H1:=REF(H ,BARSLAST(SH));
STICKLINE(H1,H1,H1,5,0),LINETHICK2,COLOR00FFFF;
DRAWTEXT(ISLASTBAR,H1*1.005,’近期高点’),COLORFFFF00;
TTP:=(CURRBARSCOUNT=5-4);
DRAWNUMBER(TTP AND H1,H1,H1),COLORFFFF00;
A2:=REF(L,N2)=LLV(L,2*N2+1);
B2:=FILTER(A2,N2);
C2:=BACKSET(B2,N2+1);
LD:=FILTER(C2,N2);
RL:=BACKSET(CURRBARSCOUNT=2,BARSLAST(LD)+1);
SL:=RL>REF(RL,1);
L1:=REF(L ,BARSLAST(SL));
STICKLINE(L1,L1,L1,5,0),COLORFFFF00,LINETHICK5;
DRAWTEXT(ISLASTBAR,L1*1.005,’近期低点’),COLORFFFF00;
DRAWNUMBER(TTP AND L1,L1,L1),COLOR00FFFF;
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),3,1),COLORRED;{红1}
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),3,0),COLORFFCC66;
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),4,1),COLORYELLOW;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),4,2),COLOR00FF00{98FD};
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3,0),COLOR00C8FF;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),2,0),COLOR10ECFF;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),2,0),COLORRED;{黄托底}
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3,0),COLOR00D900;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3,0),COLORBLUE;{蓝压顶}
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),0,0),COLOR090FF2;
FG:IF (HIGH>PEAK(1,7,1),HHV(HIGH,21),PEAK(1,7,1)),COLORGREEN;
FD:IF (LOW<TROUGH(2,7,1),LLV(LOW,21),TROUGH(2,7,1)),COLORRED;
分割0.191:(FG-FD)*0.191+FD,DOTLINE,COLORMAGENTA;
分割0.382:(FG-FD)*0.382+FD,DOTLINE,COLORCYAN;
分割0.5:(FG-FD)*0.5+FD,DOTLINE,COLORGREEN;
分割0.618:(FG-FD)*0.618+FD,DOTLINE,COLORCYAN;
分割0.809:(FG-FD)*0.809+FD,DOTLINE,COLORYELLOW;
DRAWTEXT(ISLASTBAR>0 ,ABS(分割0.191),’F0.191′)COLORMAGENTA;
DRAWTEXT(ISLASTBAR>0 ,ABS(分割0.382),’F0.382′)COLORCYAN;
DRAWTEXT(ISLASTBAR>0 ,ABS(分割0.5),’F0.500′)COLORGREEN;
DRAWTEXT(ISLASTBAR>0 ,ABS(分割0.618),’F0.618′)COLORCYAN;
DRAWTEXT(ISLASTBAR>0 ,ABS(分割0.809),’F0.809′)COLORYELLOW;

原创文章,作者:股神,如若转载,请注明出处:http://www.gupiaoxuexi.com/post/26983

发表评论

登录后才能评论