1. 首页
  2. 股票公式

通达信放量过高压主图指标公式

通达信放量过高压主图指标公式

MA1:MA(CLOSE,10)COLORWHITE,LINETHICK1;
MA2:MA(CLOSE,20)COLORYELLOW,LINETHICK1;
MA3:MA(CLOSE,55),LINETHICK1;
MA4:MA(CLOSE,251)COLORGREEN,LINETHICK1;
MA5:MA(CLOSE,500)COLORRED,LINETHICK1;
HIGHN:=10;
AA:=REF(C,HIGHN)=HHV(C,2*HIGHN+1);
QY:=BACKSET(AA,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND C=HHV(C,HIGHN+1);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(C,DDD),C);
DINGBU1:=REF(DINGBU,DDD+1);
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+10);
LOWN:=10;
AA1:=REF(L,LOWN)=LLV(L,2*LOWN+1);
QY1:=BACKSET(AA1,LOWN+1);
CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
DD1:=BARSLAST(CC1);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
GDCS2:=CONST(DINGBUTS1);
DINGBU2:=REF(DINGBU1,DDD+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);
{短T}
ZZ:=5;
AC:=REF(C,ZZ)=HHV(C,2*ZZ+1);
AD:=BACKSET(AC,ZZ+1);
AE:=FILTER(AD,ZZ) AND C=HHV(C,ZZ+1);
AF:=BARSLAST(AE);
AG:=IF(AE,CURRBARSCOUNT,0);
AH:=IF(AF,REF(C,AF),C);
AI:=IF(AF,REF(AG,AF),AG);
AL:=CONST(AI);
短T:DRAWLINE(CURRBARSCOUNT=AL,C,ISLASTBAR,REF(C,AL-1),1),DOTLINE,COLORLIBLUE,LINETHICK1;
T线:DRAWLINE(CURRBARSCOUNT=GDCS1,C,ISLASTBAR,REF(C,GDCS1-1),1)DOTLINE,COLORWHITE;
过T:IF(CROSS(C,T线),T线,DRAWNULL),CIRCLEDOT,COLORYELLOW;
DRAWICON(CROSS(C,T线),L*0.98,7);
DRAWICON(CROSS(T线,C),H*1.01,8);
DRAWICON(CROSS(C,短T),L*0.98,7);
DRAWICON(CROSS(短T,C),H*1.01,8);
{设置参数:N,1,100,10}
T1:=CONST(LLVBARS(LOW,10));
T1HIGH:=CONST(REF(HIGH,T1));
CCA:=CONST(CURRBARSCOUNT);
T2:=CONST(BARSLAST(CURRBARSCOUNT>CC+T1 AND H>T1HIGH));
T2HIGH:=CONST(REF(HIGH,T2));
T3:=CONST(BARSLAST(CURRBARSCOUNT>CC+T2 AND HIGH>T2HIGH));
T3HIGH:=CONST(REF(HIGH,T3));
猎击线:DRAWLINE(CURRBARSCOUNT=T3+1, T3HIGH, ISLASTBAR, T3HIGH, 1),LINETHICK2,COLOR0000FF;
DRAWTEXT(ISLASTBAR, T3HIGH, ‘猎击线’)LINETHICK1,COLOR0000FF;
DRAWTEXT_FIX(1,0.00,0.16,0,’筹码峰:’)COLORWHITE;
DRAWNUMBER_FIX(1,0.07,0.16,0,CONST(WINNER(C)*100))COLORWHITE;
DRAWTEXT_FIX(1,0.70,1,0,’筹码峰: (筹码90以上 线顺积极参与)’)COLORWHITE;LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),4.1,1)/SMA(ABS(CLOSE-LC),4.1,1)*100;
DRAWICON(CROSS(RSI,11) ,L*0.99,4);
VAR27:=REF(CLOSE,1);
VAR1:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>REF(ZIG(3,10),2);{ZIG? 有未来}
VAR2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<REF(ZIG(3,10),2);
STICKLINE(VAR1,C,O,4,0),COLORGREEN,LINETHICK3;{高位黄色}
STICKLINE(VAR1,C,O,3,0),COLORGREEN,LINETHICK3;{高位黄色}
STICKLINE(VAR1,H,L,1,0),COLORGREEN,LINETHICK3;{高位黄色}
STICKLINE(VAR2,C,O,4,0),COLORFF00FF,LINETHICK3;{底位红色}
STICKLINE(VAR2,C,O,3,0),COLORFF00FF,LINETHICK3;{底位红色}
STICKLINE(VAR2,H,L,1,0),COLORFF00FF,LINETHICK3;{底位红色};
DRAWNUMBER_FIX(1,0.75,1,0,CONST(WINNER(C)*100))COLORWHITE;
STICKLINE(C>REF(C,1)*1.095 AND CLOSE=HIGH,C,O,1,0)COLORYELLOW;
X1:=EMA(C,4);
X2:=REF(X1,1);
X3:=EMA(C,10);
X4:=REF(X3,1);
X5:=EMA(C,30);
X6:=REF(X5,1);
四日线斜率:=((X1-X2)/X2*100)*10;
十日线斜率:=((X3-X4)/X4*100)*10;
三十线斜率:=((X5-X6)/X6*100)*10;
涨幅:=(C/REF(C,1)-1)*100;
量比:=V/REF(MA(V,5),1);
警戒:= REF(四日线斜率,1)>0 AND REF(十日线斜率,1)>0 AND
REF(四日线斜率,1)>REF(十日线斜率,1) AND
REF(十日线斜率,1)>REF(三十线斜率,1) AND
CROSS(十日线斜率,四日线斜率) AND REF(量比,1)>REF(量比,2);
警戒线:=REF(H,BARSLAST(警戒)),COLORRED,LINETHICK1;
高压线:HHV(警戒线,120),COLORFF00FF,LINETHICK2;

原创文章,作者:股神,如若转载,请注明出处:http://www.gupiaoxuexi.com/post/27016

发表评论

登录后才能评论