1. 首页
  2. 股票公式

通达信黑马主力预判及选股指标公式

通达信黑马主力预判及选股指标公式

VAR1:=(HIGH+LOW+CLOSE*2)/4;
VAR2:=EMA(VAR1,21);
VAR3:=STD(VAR1,21);
VAR4:=((VAR1-VAR2)/VAR3*100+200)/4;
VAR5:=(EMA(VAR4,89)-25)*1.56;
VAR6:=EMA(VAR5,5)*1.22;
VAR7:=EMA(VAR6,3);
VAR8:=3*VAR6-2*VAR7;
VAR1A:=IF(CROSS(VAR6,VAR8) AND CROSS(VAR7,VAR8) AND CROSS(VAR7,VAR6),1,0);
VAR1B:=EMA(CLOSE,3)-EMA(CLOSE,89);
VAR1C:=EMA(VAR1B,21);
VAR1D:=(VAR1B-VAR1C)*10;
VAR1F:=POW(VAR1D,3)*0.1+POW(VAR1D,2);
拉升资金:IF(VAR1D>0.015,VAR1F,0)/45,COLORMAGENTA;
VAR9:=EMA(CLOSE,2)-EMA(CLOSE,55);
VAR10:=EMA(VAR9,13);
VAR11:=2*(VAR9-VAR10);
主力资金:POW(VAR11,3)*0.1+POW(VAR11,1),COLORRED;
0,COLORYELLOW;

{
选股公式:

VAR1:=(HIGH+LOW+CLOSE*2)/4;
VAR2:=EMA(VAR1,21);
VAR3:=STD(VAR1,21);
VAR4:=((VAR1-VAR2)/VAR3*100+200)/4;
VAR5:=(EMA(VAR4,89)-25)*1.56;
VAR6:=EMA(VAR5,5)*1.22;
VAR7:=EMA(VAR6,3);
VAR8:=3*VAR6-2*VAR7;
VAR1A:=IF(CROSS(VAR6,VAR8) AND CROSS(VAR7,VAR8) AND CROSS(VAR7,VAR6),1,0);
VAR1B:=EMA(CLOSE,3)-EMA(CLOSE,89);
VAR1C:=EMA(VAR1B,21);
VAR1D:=(VAR1B-VAR1C)*10;
VAR1F:=POW(VAR1D,3)*0.1+POW(VAR1D,2);
拉升资金:=IF(VAR1D>0.015,VAR1F,0)/45;
VAR9:=EMA(CLOSE,2)-EMA(CLOSE,55);
VAR10:=EMA(VAR9,13);
VAR11:=2*(VAR9-VAR10);
MA5:=EMA(C,5);
MA10:=EMA(C,10);
主力资金:=POW(VAR11,3)*0.1+POW(VAR11,1);
XG:主力资金<REF(主力资金,1)AND 主力资金>0 AND 拉升资金<=0 AND (C>MA5 OR C>MA10)
AND (REF(VOL,1)>2*REF(VOL,2) OR REF(VOL,2)>2*REF(VOL,3)AND VOL<REF(VOL,1));
}

原创文章,作者:股神,如若转载,请注明出处:http://www.gupiaoxuexi.com/post/27141

发表评论

登录后才能评论