1. 首页
  2. 股票公式

通达信V型反转主图及选股指标公式

通达信V型反转主图及选股指标公式

HT:=HHVBARS(H,15);
LT:=LLVBARS(L,15);
DF1:=(REF(C,LT)-REF(C,HT+1))/REF(C,HT+1)*100;
DF2:=(C-REF(C,LT+1))/REF(C,LT+1)*100;
TJ:=C>=REF(C,HT);
XG:=HT>LT AND DF1<-5 AND COUNT(TJ,HT+1)=1 AND TJ;
XGT:=BARSLAST(XG);
HQF:=BACKSET(XG,HT+1);
LQF:=BACKSET(XG,LT+1);
HQFT:=BARSLAST(CROSS(HQF=1,0.5));
LQFT:=BARSLAST(CROSS(LQF=1,0.5));
DRAWLINE(HQFT=0,H,LQFT=0,L,0),COLORRED,LINETHICK2;
DRAWLINE(LQFT=0,L,XG,L,0),COLORRED,LINETHICK2;
DRAWTEXT(LQFT=0,L*0.95,VARCAT(VARCAT(‘跌幅:’,VAR2STR(REFX(DF1,BARSNEXT(XGT=0)),2)),’﹪’))COLORYELLOW;
DRAWTEXT(XGT=0,H*1.02,VARCAT(VARCAT(‘涨幅:’,VAR2STR(REF(DF2,XGT),2)),’﹪’))COLORYELLOW;
STICKLINE(XG,C,O,2,0),COLORMAGENTA;
STICKLINE(XG,H,L,0,0),COLORMAGENTA;

{
选股公式:

HT:=HHVBARS(H,15);
LT:=LLVBARS(L,15);
DF1:=(REF(C,LT)-REF(C,HT+1))/REF(C,HT+1)*100;
DF2:=(C-REF(C,LT+1))/REF(C,LT+1)*100;
TJ:=C>=REF(C,HT);
HT>LT AND DF1<-5 AND COUNT(TJ,HT+1)=1 AND TJ;
}

原创文章,作者:股神,如若转载,请注明出处:http://www.gupiaoxuexi.com/post/27171

发表评论

登录后才能评论