1. 首页
  2. 股票公式

通达信熊转牛买点主图指标公式

通达信熊转牛买点主图指标公式

半分位:=(O+C)/2;
昨半分位:=REF(半分位,1);
STICKLINE(ISLASTBAR,昨半分位,昨半分位,10,0);
DRAWNUMBER(ISLASTBAR,昨半分位,昨半分位);
DRAWTEXT(ISLASTBAR,昨半分位,’ 昨半分位’);
DRAWTEXT_FIX(1,0.3,0.06,0,DYBLOCK)COLOR00FFFF;
DRAWTEXT_FIX(1,0.3,0.0,0,HYBLOCK)COLORWHITE;
DRAWTEXT_FIX(1,0.36,0.0,0,GNBLOCK)COLORWHITE;
DRAWTEXT_FIX(1,0.36,0.06,0,FGBLOCK)COLORYELLOW;
{DRAWTEXT_FIX(C>0,0.8,0.15,0,ZDBLOCK)COLORLIRED;}
DRAWTEXT_FIX(C>0,0.3,1,0,EXTERNSTR(0,1)),COLORWHITE;
ZHR:=IF(C/REF(C,1)*100-100>9.9,1,0);
STICKLINE(ZHR,OPEN,CLOSE,2,0),COLORMAGENTA;
STICKLINE(ZHR,H,L,0,0),COLORMAGENTA;
MA1:MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:MA(CLOSE,20),LINETHICK3,COLORMAGENTA;
MA4:=MA(CLOSE,60);
MA5:MA(CLOSE,60),LINETHICK3,COLOR007FFF;
MA6:MA(CLOSE,120)COLORWHITE;
MA7:MA(CLOSE,250) COLORRED;
TY:=C;
AB1:=REF(TY,10)=HHV(TY,2*10+1); BB1:=FILTER(AB1,10); CC1:=BACKSET(BB1,10+1); HHD:=FILTER(CC1,10);
AB2:=REF(TY,10)=LLV(TY,2*10+1); BB2:=FILTER(AB2,10); CC2:=BACKSET(BB2,10+1); LLD:=FILTER(CC2,10);
前期高位:REF(C,BARSLAST(HHD)),COLORYELLOW,POINTDOT;
STICKLINE(C,前期高位,前期高位,1,0),COLORYELLOW; {黄 收盘虚线};
{QAA:=REF(H,10)=HHV(H,2*10+1);
QB:=BACKSET(QAA,10+1);
QC:=FILTER(QB,10) AND H=HHV(H,10+1);
QD:=BARSLAST(QC);
QE:=IF(QC,CURRBARSCOUNT,0);
QF:=IF(QD,REF(QE,QD),QE);
QG:=CONST(QF);
QH:=REF(QF,QD+1);
QW:=CONST(QH);
{DRAWLINE(CURRBARSCOUNT=QW,H,CURRBARSCOUNT=QG,H,1),COLORBLUE,LINETHICK2;}
涨停:=IF(C/REF(C,1)*100-100>9.9,1,0);
STICKLINE(涨停,OPEN,CLOSE,2,0),COLORMAGENTA;
STICKLINE(涨停,H,L,0,0),COLORMAGENTA;
V5:=ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*57.3;
DS:=MA3>MA4 AND MA4>MA6 AND MA5>MA6 AND MA4>REF(MA4,1) AND MA5>REF(MA5,1) AND MA6>REF(MA6,1) AND IF(NAMELIKE(‘S’),0,1) AND IF(NAMELIKE(‘*’),0,1) AND EVERY(DYNAINFO(10)>1,3) {AND EVERY(TJ3,1)} ;
TJ:=H>=MA3 AND C>=REF(C,1)*1.015 AND L<=MA3 AND C>REF(C,1);
TJ2:=EXIST(TJ,3);
TJ3:=C>REF(HHV(C,3),1) AND REF(TJ2,1);
TJ4:=TJ3 AND REF(TJ3,1)=0;
DRAWTEXT(TJ4,L,’决战20线’)COLORCYAN;

原创文章,作者:股神,如若转载,请注明出处:http://www.gupiaoxuexi.com/post/27927

发表评论

登录后才能评论