1. 首页
  2. 股票公式

通达信旺财主图指标公式

通达信旺财主图指标公式

均价线:=AMOUNT/V/100;
分时均价线3:=MA(均价线,3);
分时均价线5:=MA(均价线,5);
分时均价线10:=MA(均价线,10);
分时均价线30:=MA(均价线,30);
突破:=C>分时均价线3 AND 分时均价线3<REF(分时均价线3,1)
AND REF(分时均价线3,1)<REF(分时均价线3,2)
AND REF(分时均价线3,2)<REF(分时均价线3,3);
STICKLINE(突破 ,H,L,0.3,1),COLORBROWN;
{大阴线}
C2:=REF(C,1);
大阴线:=IF((C2-C)*100/C2>=5,1,0) AND IF((C2-C)*100/C2<(10-0.01*100/C2),1,0) OR IF((O-C)*100/O>=5,1,0) AND IF((C2-C)*100/C2<(10-0.01*100/C2),1,0);
STICKLINE(大阴线,OPEN,CLOSE,-1,0),COLORGREEN;
STICKLINE(大阴线,H,L,0,1),COLORGREEN;
{无漂移买进}
A7:=C-REF(C,1);
A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);
买:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2));
DRAWTEXT(FILTER(买=1,5),LOW-0.05,’↖买进’),COLORWHITE;
STICKLINE(买,OPEN,CLOSE,2,0),COLORWHITE;
{洗盘杀入}
N:=10;
T1W:=CONST(LLVBARS(LOW,N));
T1HIGH:=CONST(REF(HIGH,T1W));
CC:=CONST(CURRBARSCOUNT);
T2:=CONST(BARSLAST((CURRBARSCOUNT >(CC+T1W)) AND (HIGH>T1HIGH)));
T2HIGH:=CONST(REF(HIGH,T2));
T3:=CONST(BARSLAST((CURRBARSCOUNT >(CC+T2)) AND (HIGH>T2HIGH)));
T3HIGH:=CONST(REF(HIGH,T3));
洗盘杀入线:DRAWLINE(CURRBARSCOUNT=T3+1, T3HIGH, ISLASTBAR, T3HIGH, 1),LINETHICK2 COLORWHITE;
DRAWTEXT(ISLASTBAR, T3HIGH, ‘ 洗盘杀入线’)LINETHICK1,COLORWHITE;
{DRAWNUMBER(ISLASTBAR,HHV(C,5)*0.95-0.01,HHV(C,5)*0.95);}{显示数字}
止损点:=(ISLASTBAR,HHV(C,5)*0.95-0.01,HHV(C,5)*0.95);
DRAWTEXT(ISLASTBAR ,止损点,’牛熊线’);
止损价:STICKLINE(ISLASTBAR,HHV(C,5)*0.95,HHV(C,5)*0.95,20,2)LINETHICK2;
{—-}
日:=50;
昨前:=3;
高2:=REF(HHV(H,日),昨前);
低2:=REF(LLV(L,日),昨前);
H4:=高2-(高2-低2)*0.618;
H5:=高2-(高2-低2)*0.809;
支撑80.9%:=REFDATE(H5,DATE),COLORRED;
支撑61.8%:=REFDATE(H4,DATE),COLORGREEN,;
STICKLINE(CURRBARSCOUNT=1,支撑80.9%,支撑80.9%,300,-1),COLORGREEN;
STICKLINE(CURRBARSCOUNT=1,支撑61.8%,支撑61.8%,300,-1),COLORRED;
DRAWTEXT(CURRBARSCOUNT=1 AND 支撑80.9%,支撑80.9%,’备钱’),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=1 AND 支撑61.8%,支撑61.8%,’买入’),COLORRED;
{进场线}
P:=21;
WH1:=IF(L=LLV(L,P),L,DRAWNULL);
WH2:=CONST(BARSLAST(WH1!=DRAWNULL));
WH3:=CONST(IF(WH2=0,H,REF(H,WH2)));
WH4:=CONST(REF(BARSLAST(H>WH3),WH2+1)+WH2+1);
WH5:=CONST(IF(WH4=0,H,REF(H,WH4)));
WH6:=CONST(REF(BARSLAST(H>WH5),WH4+1)+WH4+1);
进场:IF(CURRBARSCOUNT<=WH2+21,CONST(IF(WH6=0,H,REF(H,WH6))),DRAWNULL),COLORLIRED;
IF(CURRBARSCOUNT<=WH2+1,IF(L=LLV(L,P),L,DRAWNULL),DRAWNULL),CIRCLEDOT,COLORRED;
DRAWTEXT(CURRBARSCOUNT=INTPART((WH2+21)*0.618),进场,’进场线’),COLORWHITE;
{地域板块、所属行业、所属概念,主图显示}
DRAWTEXT_FIX(ISLASTBAR ,0.10,0.01,1,DYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR ,0.18,0.01,1,HYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR ,0.46,0.01,1,GNBLOCK),COLORWHITE;
{主图}
A:=AMOUNT/V/100;
VARA:=EMA((((A-EMA(A,13))/EMA(A,13))*(0-100)),5);
QQ:=EMA(((VARA/10)+EMA(A,13)),0);
行情线:=MA(A,1);
重心:=(C+0.618*REF(C,1)+0.382*REF(C,1)+0.236*REF(C,3)+0.146*REF(C,4))/2.382;
【操盘线】:EMA(((SLOPE(C,22)*20)+C),60),COLORYELLOW,LINETHICK1;
【黄金线】:IF(重心>=【操盘线】,【操盘线】,DRAWNULL),COLORRED,LINETHICK1;
【空仓线】:IF(重心<【操盘线】,【操盘线】,DRAWNULL),COLORCYAN,LINETHICK1;
变:EMA(CLOSE,6),LINETHICK1,COLORYELLOW;
金:IF(变>REF(变,1),变,DRAWNULL),COLORRED;
空:IF(变<REF(变,1),变,DRAWNULL),COLORGREEN;
{涨跌停显示}
涨停:=IF((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(O,1)),1,0);
STICKLINE(涨停,O,C,1,0),COLORYELLOW;
ZDF:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDF<-9.9,O,C,1,0),COLORBLUE;
VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3;
VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VAR7:=0;
VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
{成本分布———————–}
CB90:=STRCAT(‘成本90: ‘,CON2STR(COST(90),2));
CB70:=STRCAT(‘成本70: ‘,CON2STR(COST(70),2));
CB50:=STRCAT(‘成本50: ‘,CON2STR(COST(50),2));
CB30:=STRCAT(‘成本30: ‘,CON2STR(COST(30),2));
CB10:=STRCAT(‘成本10: ‘,CON2STR(COST(10),2));
CB底:=STRCAT(‘底部出击: ‘,CON2STR(COST(1),2));
DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0.06,0,’成本分布’),COLORWHITE;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.05,0.06,0,CB90),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.05,0.12,0,CB70),COLORLIGRAY;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.05,0.18,0,CB50),COLORLIBLUE;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.05,0.24,0,CB30),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.05,0.30,0,CB10),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.05,0.36,0,CB底),COLORWHITE;
上升线:=EMA(C,3),COLORRED,LINETHICK2;
下降线:=EMA(C,5),COLOR00FF00,LINETHICK2;
中间线:=EMA(下降线,5),COLORWHITE,LINETHICK2;
VAR1U:=(HIGH+LOW+OPEN+2*CLOSE)/5;
VAR2U:=REF(VAR1U,1);
VAR3U:=SMA((CLOSE-VAR2U),6,1)/SMA(ABS(CLOSE-VAR2U),6,1)*100;
VAR4U:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;
VAR5U:=EMA(0.667*REF(VAR4U,1)+0.333*VAR4U,5);
VAR6U:=IF(VOL>=1.3*MA(VOL,5) AND COUNT(VAR4U>=VAR5U AND VAR4U<-17,3) AND REF(LOW,1)=LLV(LOW,120),1,0);
VAR7U:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
VAR8U:=SMA(MAX(VAR1U-VAR2U,0),10,1)/SMA(ABS(VAR1U-VAR2U),10,1)*100;
VAR9U:=IF(COUNT(VAR8U<20,5)>=1 AND COUNT(VAR1U=LLV(VAR1U,10),10)>=1 AND CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0);
DRAWICON(FILTER(REF(VAR3U,1)>81 AND VAR3<80 OR CROSS(82,VAR7U),5),HIGH*1.018,2);
DRAWTEXT(FILTER(REF(VAR3U,1)>81 AND VAR3<80 OR CROSS(82,VAR7U),5),HIGH,’卖’),COLORYELLOW;
DRAWTEXT(FILTER(VAR9U OR VAR6U,5),LOW,’注意买入’),COLORRED;
DRAWICON(FILTER(CROSS(上升线,下降线)AND 中间线>=REF(中间线,1)AND VAR3U<50,5),L*0.992,1);

原创文章,作者:股神,如若转载,请注明出处:http://www.gupiaoxuexi.com/post/27931

发表评论

登录后才能评论