1. 首页
  2. 股票公式

通达信基准线主图指标公式

通达信基准线主图指标公式

Y:=2016;
M:=3;
D:=8;
TJ:=YEAR=Y AND MONTH=M AND DAY=D;
T1:=TJ>REF(TJ,1);
GC:=IF(T1,C,DRAWNULL);
SJ:=CONST(BARSSINCE(GC));
N:=SJ;
CP:=CONST(REF((H+L)/2,N));
DRAWKLINE(H,O,L,C);
STICKLINE(CURRBARSCOUNT > N AND C>=O,H,L,0.2,0),COLORFF00CC;
STICKLINE(CURRBARSCOUNT > N AND C>=O,C,O,3,0),COLORFF00CC;
STICKLINE(CURRBARSCOUNT > N AND C< O,H,L,0.2,0),COLOR00CC00;
STICKLINE(CURRBARSCOUNT > N AND C< O,C,O,3,0),COLOR00CC00;
HHYD:=CONST(HHV(H,N*2+1));
LLYD:=CONST(LLV(L,N*2+1));
STICKLINE(CURRBARSCOUNT==(N+1),HHYD,LLYD,0,0), COLORWHITE;
基准:DRAWLINE(CURRBARSCOUNT<=(N+2), CP, 1, CP, 0), COLORWHITE;
DRAWNUMBER(ISLASTBAR,CP,CP),COLORYELLOW;

原创文章,作者:股神,如若转载,请注明出处:http://www.gupiaoxuexi.com/post/27951

发表评论

登录后才能评论