1. 首页
  2. 股票公式

通达信多功能五合一主图主图指标公式

通达信多功能五合一主图主图指标公式

{共用均线}
MA5:MA(CLOSE,5),COLORWHITE;IF(MA5<REF(MA5,1),MA5,DRAWNULL),COLORLIGRAY;
MA10:MA(CLOSE,10),COLORYELLOW;IF(MA10<REF(MA10,1),MA10,DRAWNULL),COLOR99FFCC;
{MA20:MA(CLOSE,20),COLOR3366FF;IF(MA20<REF(MA20,1),MA20,DRAWNULL);}
MA30:MA(CLOSE,30),COLORMAGENTA;IF(MA30<REF(MA30,1),MA30,DRAWNULL),COLORCC99FF;
MA60:MA(CLOSE,60),COLORGREEN;IF(MA60<REF(MA60,1),MA60,DRAWNULL),COLOR99FF00;
MA180:MA(CLOSE,180),COLORFF9933;IF(MA180<REF(MA180,1),MA180,DRAWNULL),COLORFFFF33;
{1.离进场线}
JRH:=HHV(C,2);
JRL:=LLV(C,2);
MA3:=MA(C,3);
YTSL:=(3*C+L+O+H)/6;
Z1D:=C>=REF(C,1);Z1X:=C<=REF(C,1);
Z2D:=C>=REF(C,2);Z2X:=C<=REF(C,2);
X1D2:=Z1X AND Z2D;D1X2:=Z1D AND Z2X;
R1:=Z1D AND Z2D;
R2:=REF(R1,1) AND X1D2;
R3:=REF(R2,1) AND D1X2;
R4:=REF(R3,1) AND X1D2;
R5:=REF(R4,1) AND D1X2;
R6:=REF(R5,1) AND X1D2;
R7:=REF(R6,1) AND D1X2;
R8:=REF(R7,1) AND X1D2;
R9:=REF(R8,1) AND D1X2;
RA:=REF(R9,1) AND X1D2;
RB:=REF(RA,1) AND D1X2;
RC:=REF(RB,1) AND X1D2;
RD:=Z1X AND Z2X;
RE:=REF(RD,1) AND D1X2;
RF:=REF(RE,1) AND X1D2;
R10:=REF(RF,1) AND D1X2;
R11:=REF(R10,1) AND X1D2;
R12:=REF(R11,1) AND D1X2;
R13:=REF(R12,1) AND X1D2;
R14:=REF(R13,1) AND D1X2;
R15:=REF(R14,1) AND X1D2;
R16:=REF(R15,1) AND D1X2;
R17:=REF(R16,1) AND X1D2;
R18:=REF(R17,1) AND D1X2;
R19:=((REF(RD OR RE OR RF OR R10 OR R11 OR R12 OR R13 OR R14 OR R15 OR R16 OR R17 OR R18,1)) AND R1);
R1A:=((REF(R1 OR R2 OR R3 OR R4 OR R5 OR R6 OR R7 OR R8 OR R9 OR RA OR RB OR RC,1)) AND RD);
红色持股:=R1 OR R2 OR R3 OR R4 OR R5 OR R6 OR R7 OR R8 OR R9 OR RA OR RB OR RC,COLOR0000FF,NODRAW;
离场:=IF(红色持股,JRL,DRAWNULL);
明离场价:=离场,COLORFF99FF,NODRAW;
今离场价:REF(离场,1)COLORGREEN,NODRAW;
青色观望:=RD OR RE OR RF OR R10 OR R11 OR R12 OR R13 OR R14 OR R15 OR R16 OR R17 OR R18,COLORFFFF00,NODRAW;
进:=IF(青色观望,JRH,DRAWNULL);
明进场价:=进,COLOR33AACC,NODRAW;
今进场价:REF(明进场价,1),COLORRED,NODRAW;
短买:R19,COLORLIRED,NODRAW;
STICKLINE(ISLASTBAR AND (红色持股 OR REF(红色持股,1)=1),今离场价,今离场价,30,1),COLOR0000FF;
STICKLINE(ISLASTBAR AND (青色观望 OR REF(青色观望,1)=1),今进场价,今进场价,30,1),COLOR00FF00;
{2.解盘}
QLIFE:=(EMA(CLOSE,60)+EMA(CLOSE,90))/2,POINTDOT,COLORGREEN,LINETHICK4;
TT:=240/FROMOPEN;
比:=TT;
J12:=(HIGH – ((HIGH – LOW) / 3));
J23:=(LOW + ((HIGH – LOW) / 3));
AAA:=CONST(HHV(H,90));
BBB:=CONST(LLV(L,100));
DRAWKLINE(H,O,L,C);
T1{早晨之星}:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1)
< REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2)),1,0));
T2{黄昏之星}:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2) > 1.03 AND REF(OPEN,1)
> REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.02
AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,2)),1,0));
T3{长十字}:=CONST(IF((CLOSE=OPEN AND HIGH/LOW >1.03),1,0));
T4{垂死十字}:=CONST(IF((CLOSE=OPEN AND CLOSE=LOW AND CLOSE!=HIGH),1,0));
T5{早晨十字星}:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1)
< REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2)),1,0));
T6{黄昏十字星}:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2) > 1.05 AND REF(OPEN,1)
> REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN<0.95 AND CLOSE<REF(CLOSE,2)),1,0));
T7{射击之星}:=CONST(IF((MIN(OPEN,CLOSE)=LOW AND HIGH-LOW >
3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE > MA(CLOSE,5)),1,0));
T8{倒转锤头}:=CONST(IF((MIN(OPEN,CLOSE)=LOW AND HIGH-LOW >
3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE < MA(CLOSE,5)),1,0));
T9{锤头}:=CONST(IF((HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW >
3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE < MA(CLOSE,5)),1,0));
T10{吊颈}:=CONST(IF((HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW >
3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE>MA(CLOSE,5)),1,0));
T11{穿头破脚}:=CONST(IF(((REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96
AND CLOSE<REF(OPEN,1)
AND OPEN>REF(CLOSE,1))OR (REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04
AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1))),1,0));
T12{乌云盖顶}:=CONST(IF((REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.97
AND OPEN>REF(CLOSE,1) AND CLOSE<REF(CLOSE,1)),1,0));
T13{曙光初现}:=CONST(IF((REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03
AND OPEN<REF(CLOSE,1) AND CLOSE>REF(CLOSE,1)),1,0));
T14{身怀六甲}:=CONST(IF((ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04
AND ABS(CLOSE-OPEN)/CLOSE<0.005 AND
MAX(CLOSE,OPEN) < MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN)
> MIN(REF(CLOSE,1),REF(OPEN,1))),1,0));
T15{十字胎}:=CONST(IF((ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04
AND CLOSE=OPEN AND
CLOSE < MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE > MIN(REF(CLOSE,1)
,REF(OPEN,1))),1,0));
T16{平顶}:=CONST(IF((ABS(HIGH-REF(HIGH,1))/HIGH<0.001),1,0));
T17{平底}:=CONST(IF(((ABS(LOW-REF(LOW,1))/LOW<0.001 AND ABS(REF(LOW,1)
-REF(LOW,2))/REF(LOW,1)<=0.001)),1,0));
T18{大阳烛}:=CONST(IF((CLOSE/OPEN>1.05 AND HIGH/LOW < CLOSE/OPEN+0.018),1,0));
T19{三个白武士}:=CONST(IF((REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)
>REF(OPEN,1) AND CLOSE>OPEN
AND REF(CLOSE,1)>REF(CLOSE,2) AND CLOSE>REF(CLOSE,1)),1,0));
T20{双飞乌鸦}:=CONST(IF((REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN
AND CLOSE/OPEN<0.98),1,0));
T21{孕育线}:=CONST(IF((REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,2)
-REF(OPEN,2))/REF(OPEN,2)>=2/100 AND REF(OPEN,1)>=REF(CLOSE,1)
AND (REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<=2/100 AND REF(OPEN,1)
<=REF(CLOSE,2) AND REF(CLOSE,1)>=REF(OPEN,2) AND C>=OPEN
AND (CLOSE-OPEN)/OPEN>=2/100 AND CLOSE>=REF(OPEN,1) AND OPEN<=REF(CLOSE,1)
AND (MAX(CLOSE,REF(C,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))
<=1/100),1,0));
T22{多方炮}:=CONST(IF((REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1)
AND CLOSE>OPEN),1,0));
T23{出水芙蓉}:=CONST(IF(((OPEN<EMA(C,20) OR OPEN<EMA(C,40) OR OPEN<
EMA(C,60)) AND (C>MAX(EMA(C,20),MAX(EMA(C,40),EMA(C,60))))AND (V/MA(V,30)
>1.2 AND C/REF(C,1)>1.049)),1,0));
T24{上升三部曲}:=CONST(IF((REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3)
<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1)
AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)
<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2)
AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,4)),1,0));
T25{下跌三部曲}:=CONST(IF(( REF(CLOSE,4)/REF(OPEN,4)<0.97 AND REF(CLOSE,3)
>REF(OPEN,3) AND REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1)
AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)
<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN<0.97 AND
CLOSE<REF(CLOSE,4)),1,0));
T26{跳空缺口}:=CONST(IF(HIGH<REF(LOW,1) OR LOW>REF(HIGH,1),1,0));
T27{三只乌鸦}:=CONST(IF((REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)
<REF(OPEN,1) AND CLOSE<OPEN AND REF(CLOSE,1)<REF(CLOSE,2)
AND CLOSE<REF(CLOSE,1)),1,0));
T28{光脚阴线}:=CONST(IF((LOW=CLOSE AND HIGH!=LOW),1,0));
T29{光头阳线}:=CONST(IF((HIGH=CLOSE AND HIGH!=LOW),1,0));
T30{分离}:=CONST(IF((OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)
-REF(OPEN,1))<0),1,0));
T31{长下影}:=CONST(IF(((MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.667),1,0));
T32{长上影}:=CONST(IF(((HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667),1,0));
T33{十字星}:=CONST(IF((CLOSE=OPEN AND HIGH!=LOW),1,0));
T34{大阴烛}:=CONST(IF((OPEN/CLOSE > 1.05 AND HIGH/LOW < OPEN/CLOSE+0.018),1,0));
T35{好友反攻}:=CONST(IF(((REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN
AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002) OR (REF(CLOSE,1)>REF(OPEN,1)
AND CLOSE<OPEN AND ABS(CLOSE-REF(CLOSE,1))
/CLOSE<0.002)),1,0));
T36{倾盆大雨}:=CONST(IF((REF(C,1)/REF(O,1)>=1.03 AND O<REF(C,1) AND O
>REF(O,1) AND C<REF(O,1)),1,0));
T37{M9}:=CONST(V*比>REF(V,1) AND MA(V,5)>REF(MA(V,5),1));
T38{M10}:=CONST(V*比<REF(V,1) AND MA(V,5)>REF(MA(V,5),1));
T39{M11}:=CONST(V*比>REF(V,1)AND MA(V,5)<REF(MA(V,5),1));
T40{M12}:=CONST(V*比<REF(V,1)AND MA(V,5)<REF(MA(V,5),1));
T41{M13}:=CONST((((IF((CLOSE = OPEN),1,0) + IF((CLOSE >= J12),1,0)) + IF((CLOSE <= J23),1,0)) > 1));
T42{M14}:=CONST((((AMOUNT / VOL) / 100) > REF(HIGH,1)));
T43{M15}:=CONST((((AMOUNT / VOL) / 100) < REF(LOW,1)));
TS1:=IF(T1=1,0.05,0);
TS2:=IF(T2=1,TS1+0.05,TS1);
TS3:=IF(T3=1,TS2+0.05,TS2);
TS4:=IF(T4=1,TS3+0.05,TS3);
TS5:=IF(T5=1,TS4+0.05,TS4);
TS6:=IF(T6=1,TS5+0.05,TS5);
TS7:=IF(T7=1,TS6+0.05,TS6);
TS8:=IF(T8=1,TS7+0.05,TS7);
TS9:=IF(T9=1,TS8+0.05,TS8);
TS10:=IF(T10=1,TS9+0.05,TS9);
TS11:=IF(T11=1,TS10+0.05,TS10);
TS12:=IF(T12=1,TS11+0.05,TS11);
TS13:=IF(T13=1,TS12+0.05,TS12);
TS14:=IF(T14=1,TS13+0.05,TS13);
TS15:=IF(T15=1,TS14+0.05,TS14);
TS16:=IF(T16=1,TS15+0.05,TS15);
TS17:=IF(T17=1,TS16+0.05,TS16);
TS18:=IF(T18=1,TS17+0.05,TS17);
TS19:=IF(T19=1,TS18+0.05,TS18);
TS20:=IF(T20=1,TS19+0.05,TS19);
TS21:=IF(T21=1,TS20+0.05,TS20);
TS22:=IF(T22=1,TS21+0.05,TS21);
TS23:=IF(T23=1,TS22+0.05,TS22);
TS24:=IF(T24=1,TS23+0.05,TS23);
TS25:=IF(T25=1,TS24+0.05,TS24);
TS26:=IF(T26=1,TS25+0.05,TS25);
TS27:=IF(T27=1,TS26+0.05,TS26);
TS28:=IF(T28=1,TS27+0.05,TS27);
TS29:=IF(T29=1,TS28+0.05,TS28);
TS30:=IF(T30=1,TS29+0.05,TS29);
TS31:=IF(T31=1,TS30+0.05,TS30);
TS32:=IF(T32=1,TS31+0.05,TS31);
TS33:=IF(T33=1,TS32+0.05,TS32);
TS34:=IF(T34=1,TS33+0.05,TS33);
TS35:=IF(T35=1,TS34+0.05,TS34);
TS36:=IF(T36=1,TS35+0.05,TS35);
TS37:=IF(T37=1,TS36+0.05,TS36);
TS38:=IF(T38=1,TS37+0.05,TS37);
TS39:=IF(T39=1,TS38+0.05,TS38);
TS40:=IF(T40=1,TS39+0.05,TS39);
TS41:=IF(T41=1,TS40+0.05,TS40);
TS42:=IF(T42=1,TS41+0.05,TS41);
TS43:=IF(T43=1,TS42+0.05,TS42);
DRAWTEXT_FIX(T1=1 ,0.01,TS1,0,’早晨之星,见底回升’),COLORLIRED;
DRAWTEXT_FIX(T2=1 ,0.01,TS2,0,’黄昏之星,见顶回落’),COLORGREEN;
DRAWTEXT_FIX(T3=1 ,0.01,TS3,0,’长十字,重要的警告信号,原趋势停顿或反转’),COLORYELLOW;
DRAWTEXT_FIX(T4=1 ,0.01,TS4,0,’垂死十字,下跌信号’),COLORGREEN ;
DRAWTEXT_FIX(T5=1 ,0.01,TS5,0,’早晨十字星,上涨信号,见底回升’),COLORRED;
DRAWTEXT_FIX(T6=1 ,0.01,TS6,0,’黄昏十字星,趋势停顿或反转,下跌,或见顶回落’),COLORGREEN ;
DRAWTEXT_FIX(T7=1 ,0.01,TS7,0,’射击之星,市场顶部就在眼前,可能见顶回落,可靠性低’),COLORGREEN;
DRAWTEXT_FIX(T8=1 ,0.01,TS8,0,’倒转锤头构成一个看涨信号,可能见底回升’),COLORRED;
DRAWTEXT_FIX(T9=1 ,0.01,TS9,0,’锤头,可能见底回升,如有量配合,信号强烈’),COLORRED;
DRAWTEXT_FIX(T10=1 ,0.01,TS10,0,’吊颈,上升行情中见顶回落,顶部出现为见顶信号’),COLORGREEN;
DRAWTEXT_FIX(T11=1 ,0.01,TS11,0,’穿头破脚,顶部出现,见顶回落信号’),COLORGREEN;
DRAWTEXT_FIX(T12=1 ,0.01,TS12,0,’乌云盖顶,见顶回落信号’),COLORGREEN ;
DRAWTEXT_FIX(T13=1 ,0.01,TS13,0,’曙光初现,将演化为V型反转或横盘。后市见底回升’),COLORRED;
DRAWTEXT_FIX(T14=1 ,0.01,TS14,0,’身怀六甲,底部时见底回升,顶部时见顶回落信号’),COLORYELLOW;
DRAWTEXT_FIX(T15=1 ,0.01,TS15,0,’十字胎,或反转’),COLOR00FFFF;
DRAWTEXT_FIX(T16=1 ,0.01,TS16,0,’平顶,行情见顶,股价将反转。但下跌力度较小’),COLORYELLOW;
DRAWTEXT_FIX(T17=1 ,0.01,TS17,0,’平底,行情探低见底,股价行将反转上升,但力度较小’),COLORLIRED;
DRAWTEXT_FIX(T18=1 ,0.01,TS18,0,’大阳烛,上升中,剧烈地向上攀升。下行中,剧烈地向上反弹’),COLORYELLOW ;
DRAWTEXT_FIX(T19=1 ,0.01,TS19,0,’三个白武士,每日收盘价上移,表示可能见底回升’),COLORRED;
DRAWTEXT_FIX(T20=1 ,0.01,TS20,0,’双飞乌鸦,行情开始疲软将见顶回落’),COLORGREEN ;
DRAWTEXT_FIX(T21=1 ,0.01,TS21,0,’孕育线,注意股价位置’),COLORYELLOW ;
DRAWTEXT_FIX(T22=1 ,0.01,TS22,0,’多方炮,底部可能上涨,中间上涨中继,顶部见顶信号’),COLORLIRED;
DRAWTEXT_FIX(T23=1 ,0.01,TS23,0,’出水芙蓉,阳线穿过20、40、60日均线,上攻势头初现’),COLORRED ;
DRAWTEXT_FIX(T24=1 ,0.01,TS24,0,’上升三部曲,上涨信号’),COLORRED ;
DRAWTEXT_FIX(T25=1 ,0.01,TS25,0,’下跌三部曲,下跌信号’),COLORGREEN;
DRAWTEXT_FIX(T26=1 ,0.01,TS26,0,’跳空缺口,突破盘整,向上涨、向下跌开始’),COLORYELLOW ;
DRAWTEXT_FIX(T27=1 ,0.01,TS27,0,’三只乌鸦站枝头,可能见顶回落’),COLORYELLOW ;
DRAWTEXT_FIX(T31=1 ,0.01,TS31,0,’长下影,有可能止跌回升,升势末期,须小心’),COLORYELLOW;
DRAWTEXT_FIX(T32=1 ,0.01,TS32,0,’长上影,表明行情上档压力沉重,升势受阻’),COLORYELLOW ;
DRAWTEXT_FIX(T35=1 ,0.01,TS35,0,’好友反攻,跌势已尽,要展开一段反弹行情’),COLORLIRED;
DRAWTEXT_FIX(T36=1 ,0.01,TS36,0,’倾盆大雨,见顶信号’),COLORGREEN;
DRAWTEXT_FIX(T37=1 ,0.01,TS37,0,’今日成交量大于昨日,且有继续增大趋势’),COLORYELLOW ;
DRAWTEXT_FIX(T38=1 ,0.01,TS38,0,’今日成交量小于昨日,但有放大迹象’),COLORFFFF00 ;
DRAWTEXT_FIX(T39=1 ,0.01,TS39,0,’今日成交量大于昨日, 但有缩小迹象’),COLORLIRED ;
DRAWTEXT_FIX(T40=1 ,0.01,TS40,0,’今日成交量小于昨日,且有缩小迹象’),COLOR99FFFF ;
DRAWTEXT_FIX(T41=1 ,0.01,TS41,0,’极端行情,在未来的几日内有85%的机会变更方向’),COLORWHITE ;
DRAWTEXT_FIX(T42=1 ,0.01,TS42,0,’上涨趋势’),COLORRED ;
DRAWTEXT_FIX(T43=1 ,0.01,TS43,0,’下跌趋势’),COLORGREEN;
{3.K线买卖提示}
升:=EMA(C,2),COLOR000000;
降:=EMA(SLOPE(C,12)*20+C,30),COLOR000000;{降:=EMA(SLOPE(C,21)*20+C,42),COLOR000000;}
买:=CROSS(升,降);
卖:=CROSS(降,升);
DRAWTEXT(买,L*0.95,’↖B’),COLORLIRED;
DRAWTEXT(卖,H*1.05,’↙S’),COLORLIGREEN;
{4.有未来买卖提示}
BUY1:=ZIG(3,10);
SELL1:=MA(BUY1,2);
DRAWICON(CROSS(BUY1,SELL1),L-0.3,7);
DRAWICON(CROSS(SELL1,BUY1),H+0.2,8);
STICKLINE(BUY1>SELL1 AND O>=C,C,O,-1,0),COLORRED;
STICKLINE(BUY1>SELL1 AND O>=C,L,H,0,0),COLORRED;
STICKLINE(BUY1<SELL1 AND O<=C,O,C,-1,1),COLORCYAN;
STICKLINE(BUY1<SELL1 AND O<=C,O,L,0,1),COLORCYAN;
STICKLINE(BUY1<SELL1 AND O<=C,C,H,0,1),COLORCYAN;
平均:=(L+H)/2;
KB:=ZIG(平均,10);
KS:=MA(KB,2);
DRAWICON(CROSS(KB,KS),L-0.7,1);
DRAWICON(CROSS(KS,KB),H+0.6,2);
{5.财务板块}
DRAWTEXT_FIX(1,0.65,0.018,0,’市盈率:’),COLORYELLOW;
DRAWNUMBER_FIX(1,0.7,0.018,0,CONST(DYNAINFO(39))),COLORYELLOW;
DRAWTEXT_FIX(1,0.76,0.02,0,’市净率:’),COLOR0080FF;
DRAWNUMBER_FIX(1,0.81,0.02,0,CONST(C/FINANCE(34))),COLOR0080FF;
DRAWTEXT_FIX(1,0.86,0.018,0,’每股收益(元):’),COLORFF00FF;
DRAWNUMBER_FIX(1,0.95,0.018,0,CONST(FINANCE(33))),COLORFF00FF;
Z1:=STRCAT(HYBLOCK,’ ‘);
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,’ ‘);
DRAWTEXT_FIX(ISLASTBAR,0.98,1,1,STRCAT(Z3,GNBLOCK)),COLORYELLOW;

原创文章,作者:股神,如若转载,请注明出处:http://www.gupiaoxuexi.com/post/27967

发表评论

登录后才能评论