1. 首页
  2. 股票公式

通达信精准背离指标公式

通达信精准背离指标公式

MA(C,5);
趋势线:MA(C,12),COLORRED;
IF(趋势线>REF(趋势线,1),趋势线,DRAWNULL),COLORRED;
IF(趋势线<REF(趋势线,1),趋势线,DRAWNULL),COLORGREEN;
A1:=BARSLAST(REF(CROSS(“MACD.DIF”(12,26,9),”MACD.DEA”(12,26,9)),1));
B1:=REF(C,A1+1)>C AND REF(“MACD.DIF”(12,26,9),A1+1)<“MACD.DIF”(12,26,9) AND CROSS(“MACD.DIF”(12,26,9),”MACD.DEA”(12,26,9));
底背离MACD:DRAWTEXT(FILTER(B1>0,5),LOW,’△’),COLORYELLOW;
DRAWTEXT(FILTER(B1>0,5),LOW*0.98,’MACD底背离’),COLOR00FF00;
A2:=BARSLAST(REF(CROSS(“KDJ.K”(9,3,3),”KDJ.D”(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF(“KDJ.K”(9,3,3),A2+1)<“KDJ.K”(9,3,3) AND CROSS(“KDJ.K”(9,3,3),”KDJ.D”(9,3,3));
底背离KDJ:DRAWTEXT(FILTER(B2>0,5),LOW,’△’),COLORYELLOW;
DRAWTEXT(FILTER(B2>0,5),LOW*0.98,’KDJ底背离’),COLORRED;
A3:=BARSLAST(REF(CROSS(“RSI.RSI1″(8,55,55),”RSI.RSI2″(8,55,55)),1));
B3:=REF(C,A3+1)>C AND REF(“RSI.RSI1″(8,55,55),A3+1)<“RSI.RSI1″(8,55,55) AND CROSS(“RSI.RSI1″(8,55,55),”RSI.RSI2″(8,55,55));
底背离RSI:DRAWTEXT(FILTER(B3>0,5),LOW,’△’),COLORYELLOW;
DRAWTEXT(FILTER(B3>0,5),LOW*0.98,’RSI底背离’),COLORF0F000;
C1:=BARSLAST(REF(CROSS(“MACD.DEA”(12,26,9),”MACD.DIF”(12,26,9)),1));
D1:=REF(C,C1+1)<C AND REF(“MACD.DIF”(12,26,9),C1+1)>”MACD.DIF”(12,26,9) AND CROSS(“MACD.DEA”(12,26,9),”MACD.DIF”(12,26,9));
顶背离MACD:DRAWTEXT(FILTER(D1>0,5),HIGH*1.02,’▽’),COLOR00FF00;
DRAWTEXT(FILTER(D1>0,5),HIGH*1.04,’MACD顶背离’),COLORRED;
C2:=BARSLAST(REF(CROSS(“KDJ.D”(9,3,3),”KDJ.K”(9,3,3)),1));
D2:=REF(C,C2+1)<C AND REF(“KDJ.K”(9,3,3),C2+1)>”KDJ.K”(9,3,3) AND CROSS(“KDJ.D”(9,3,3),”KDJ.K”(9,3,3));
顶背离KDJ:DRAWTEXT(FILTER(D2>0,5),HIGH*1.02,’▽’),COLOR00FF00;
DRAWTEXT(FILTER(D2>0,5),HIGH*1.04,’KDJ顶背离’),COLORF00FF0;
C3:=BARSLAST(REF(CROSS(“RSI.RSI2″(8,55,55),”RSI.RSI1″(8,55,55)),1));
D3:=REF(C,C3+1)<C AND REF(“RSI.RSI1″(8,55,55),C3+1)>”RSI.RSI1″(8,55,55) AND CROSS(“RSI.RSI2″(8,55,55),”RSI.RSI1″(8,55,55));
顶背离RSI:DRAWTEXT(FILTER(D3>0,5),HIGH*1.02,’▽’),COLOR00FF00;
DRAWTEXT(FILTER(D3>0,5),HIGH*1.04,’RSI顶背离’),COLORYELLOW;

原创文章,作者:股神,如若转载,请注明出处:http://www.gupiaoxuexi.com/post/27997

发表评论

登录后才能评论