1. 首页
  2. 股票公式

通达信25种涨停基因选股指标公式

通达信25种涨停基因选股指标公式

峰谷虚实:=1;
峰谷周期:=5;
高量周期:=11;
M周期内:=9;
等于或大于:=1;
N个基因:=10;
XA_1:=1999231;{这里是修改使用期限的}
XA_2:=TESTSKIP(DATE>XA_1);
XA_3:=REF(CLOSE,1);
XA_4:=ISLASTBAR AND CLOSE<500;
XA_5:=VOL;
XA_6:=MA(VOL,5);
XA_7:=XA_5<=LLV(XA_5,100)*1;
XA_8:=COUNT(XA_7,5)>=3 OR XA_6<=LLV(XA_6,100) AND XA_5>0 AND BARSCOUNT(XA_5)>=100;
XA_9:=VOL>=REF(VOL,1)*1.9 AND CLOSE>XA_3;
XA_10:=HIGH<0.382*HHV(HIGH,240) OR LOW<1.382*LLV(LOW,240);
XA_11:=VOL<0.382*HHV(VOL,240) AND MA(VOL,5)<=MA(VOL,40);
XA_12:=XA_11 AND XA_10;
XA_13:=VOL/REF(VOL,1)>=1.1;
XA_14:=CLOSE>OPEN AND BETWEEN(VOL/REF(VOL,1),1.1,2.5);
XA_15:=CLOSE>REF(CLOSE,1) AND REFX(LLV(MIN(CLOSE,OPEN),3),3)>=LOW;
XA_16:=XA_13 AND XA_15;
XA_17:=XA_16 AND XA_12;
XA_18:=LLV(MIN(OPEN,CLOSE),3);
XA_19:=0.97*MA(VOL,3)<=REF(VOL,3);
XA_20:=REF(CLOSE>XA_3 AND VOL>1.1*REF(VOL,1),3) AND CLOSE>=REF(CLOSE,3) AND REF(CLOSE>=OPEN,3) AND XA_18>=REF(OPEN,3) AND XA_19;
XA_21:=REFX(XA_20,3);
XA_22:=CLOSE>OPEN AND CLOSE<REFX(OPEN,1) AND REFX(XA_15,1);
XA_23:=BARSLAST(XA_20);
XA_24:=REF(XA_18,XA_23);
XA_25:=REF(CLOSE,XA_23+3);
XA_26:=REF(OPEN,XA_23+3);
XA_27:=50/IF(CLOSE>=1,10000,100000);
XA_28:=1.1*XA_3-XA_27;
XA_29:=1.05*XA_3-XA_27;
XA_30:=0.9*XA_3+XA_27;
XA_31:=0.95*XA_3+XA_27;
XA_32:=NAMELIKE(4) OR NAMELIKE(5);
XA_33:=IF(XA_32,CLOSE>=XA_29,CLOSE>=XA_28);
XA_34:=CLOSE<OPEN AND (CLOSE<=XA_31 OR CLOSE<0.95*OPEN+XA_27) OR (CLOSE>1000 AND CLOSE<=XA_3*0.975);
XA_35:=XA_34;
XA_36:=BARSLAST(FILTER(XA_35,3));
XA_37:=REF(OPEN,XA_36);
XA_38:=LOW>REF(HIGH,1);
XA_39:=峰谷周期;
XA_40:=IF(峰谷虚实=0,HIGH,MAX(CLOSE,OPEN));
XA_41:=5;
XA_42:=XA_41*1;
XA_43:=BARSLAST(FILTER(BACKSET(FILTER(REF(XA_40,XA_42)=HHV(XA_40,2*XA_42+1),XA_42),XA_42+1),XA_42));
XA_44:=REF(XA_40,XA_43);
XA_45:=XA_41*2;
XA_46:=BARSLAST(FILTER(BACKSET(FILTER(REF(XA_40,XA_45)=HHV(XA_40,2*XA_45+1),XA_45),XA_45+1),XA_45));
XA_47:=REF(XA_40,XA_46);
XA_48:=XA_41*4;
XA_49:=BARSLAST(FILTER(BACKSET(FILTER(REF(XA_40,XA_48)=HHV(XA_40,2*XA_48+1),XA_48),XA_48+1),XA_48));
XA_50:=REF(XA_40,XA_49);
XA_51:=XA_41*8;
XA_52:=BARSLAST(FILTER(BACKSET(FILTER(REF(XA_40,XA_51)=HHV(XA_40,2*XA_51+1),XA_51),XA_51+1),XA_51));
XA_53:=REF(XA_40,XA_52);
XA_54:=1+0/100;
XA_55:=CROSS(CLOSE,XA_54*XA_44);
XA_56:=XA_55 AND REF(HHV(XA_40,XA_43),1)<=XA_44;
XA_57:=CROSS(CLOSE,XA_54*XA_47);
XA_58:=XA_57 AND REF(HHV(XA_40,XA_46),1)<=XA_47;
XA_59:=CROSS(CLOSE,XA_54*XA_50);
XA_60:=XA_59 AND REF(HHV(XA_40,XA_49),1)<=XA_50;
XA_61:=CROSS(CLOSE,XA_54*XA_53);
XA_62:=XA_61 AND REF(HHV(XA_40,XA_52),1)<=XA_53;
XA_63:=XA_56 OR XA_60 OR XA_60 OR XA_62;
XA_64:=IF(XA_56,XA_43,IF(XA_58,XA_46,IF(XA_60,XA_49,XA_52)));
XA_65:=REF(XA_40,XA_64);
XA_66:=IF(峰谷虚实=0,LOW,MIN(CLOSE,OPEN));
XA_67:=FILTER(BACKSET(FILTER(REF(XA_66,XA_39)=LLV(XA_66,2*XA_39+1),XA_39),XA_39+1),XA_39);
XA_68:=BARSLAST(XA_67);
XA_69:=REF(XA_66,XA_68);
XA_70:=0.002*LOW+0.005;
XA_71:=XA_5/HHV(XA_5,20)<=0.618;
XA_72:=HIGH>LOW AND (CLOSE/REF(CLOSE,1)<=0.96 OR CLOSE/OPEN<=0.96) AND XA_71;
XA_73:=HIGH>LOW AND (CLOSE/REF(CLOSE,1)>=1.04 OR CLOSE/OPEN>=1.04) AND XA_71;
XA_74:=LOW*0.005;
XA_75:=LOW<=LLV(LOW,3);
XA_76:=ABS(LOW-REF(XA_24,1))<=XA_74 OR ABS(LOW-REF(XA_24,XA_23+1))<=XA_74 AND LOW<=LLV(MIN(OPEN,CLOSE),XA_23);
XA_77:=ABS(LOW-REF(XA_25,1))<=XA_74 OR ABS(LOW-REF(XA_25,XA_23+1+3))<=XA_74;
XA_78:=ABS(LOW-REF(XA_26,1))<=XA_74 OR ABS(LOW-REF(XA_26,XA_23+1+3))<=XA_74;
XA_79:=ABS(LOW-REF(XA_65,1))<=XA_74 OR ABS(LOW-REF(XA_65,XA_64+1))<=XA_74;
XA_80:=ABS(LOW-REF(XA_69,1))<=XA_74 OR ABS(LOW-REF(XA_69,XA_68+1))<=XA_74;
XA_81:=ABS(LOW-REF(XA_37,1))<=XA_74 AND XA_36>=1;
XA_82:=XA_75 AND (XA_76 OR XA_79 OR XA_80 OR XA_81 OR XA_77 OR XA_78);
XA_83:=CLOSE>OPEN AND CLOSE<REF(CLOSE,1);
XA_84:=CLOSE<OPEN AND CLOSE>REF(CLOSE,1);
XA_85:=AMOUNT/VOL/100;
XA_86:=CLOSE<OPEN AND XA_85>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,1) AND XA_85<=HIGH;
XA_87:=XA_84 OR XA_86;
XA_88:=CLOSE>OPEN AND CLOSE>XA_3 AND VOL<REF(VOL,1);
XA_89:=REF(VOL,1)>=VOL*1.9 AND REF(CLOSE>REF(CLOSE,1),1);
XA_90:=COUNT(XA_9,3)=1 AND XA_89;
XA_91:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
XA_92:=SUM(XA_91,3)<=(-5);
XA_93:=CLOSE>OPEN AND CLOSE>REF((OPEN+CLOSE)/2,1);
XA_94:=REF(XA_92,1) AND XA_93;
XA_95:=MIN(CLOSE,OPEN)>REF(MAX(CLOSE,OPEN),1);
XA_96:=COUNT(XA_95,3)=3;
XA_97:=HIGH=LOW;
XA_98:=COUNT(XA_97,3)=3=0 AND XA_97=0;
XA_99:=XA_96 AND XA_98;
XA_100:=COUNT(CLOSE>=XA_3,3)=3 AND REF(COUNT(VOL>=REF(VOL,1),2)=2,1);
XA_101:=(CLOSE-OPEN)/OPEN*100>=3;
XA_102:=BETWEEN(MIN(CLOSE,OPEN),REF(OPEN+(CLOSE-OPEN)*0.6,1),REF(CLOSE,1)) AND CLOSE<XA_3;
XA_103:=VOL/REF(VOL,1)<=0.71;
XA_104:=REF(XA_101,1) AND XA_102 AND XA_103;
XA_105:=4;
XA_106:=IF(峰谷虚实=1,MIN(CLOSE,OPEN),LOW);
XA_107:=BARSLAST(XA_9);
XA_108:=LLV(XA_106,XA_107)>=REF(XA_106,XA_107) AND XA_107>=XA_105;
XA_109:=FILTER(BACKSET(FILTER(REF(VOL,XA_39)=HHV(VOL,2*XA_39+1),XA_39),XA_39+1),XA_39);
XA_110:=BARSLAST(XA_109);
XA_111:=LLV(XA_106,XA_110)>=REF(XA_106,XA_110) AND XA_110>=XA_105 AND XA_110>=高量周期;
XA_112:=LOW>REF(HIGH,1);
XA_113:=BARSLAST(XA_9);
XA_114:=LLV(LOW,XA_113)>REF(HIGH,XA_113+1) AND XA_113>=XA_105;
XA_115:=XA_108 OR XA_111 OR XA_114;
XA_116:=MIN(CLOSE,OPEN);
XA_117:=MAX(CLOSE,OPEN);
XA_118:=HIGH-LOW;
XA_119:=CLOSE>=1.0497*REF(CLOSE,1)-XA_27;
XA_120:=RANGE(ABS(CLOSE-OPEN)/XA_118,0,0.8) AND (HIGH-XA_117)/XA_118>=0.1 AND (XA_116-LOW)/XA_118>=0.1;
XA_121:=LLV(XA_116,2)>=REF(0.5*(XA_117+XA_116),2);
XA_122:=HHV(VOL,2)<REF(VOL,2);
XA_123:=REF(XA_119,2) AND COUNT(XA_120,2)=2 AND XA_121 AND XA_122;
XA_124:=LLV(XA_116,3);
XA_125:=(CLOSE-OPEN)/OPEN>=5/100 OR XA_91>=5;
XA_126:=20;
XA_127:=(XA_116-LLV(XA_116,4))/LLV(XA_116,4)<3/100;
XA_128:=LLV(XA_116,5)=LLV(XA_116,XA_126) AND BARSCOUNT(CLOSE)>=XA_126;
XA_129:=0;
XA_130:=IF(XA_129=1,CLOSE>=OPEN AND REF(XA_125=0 OR CLOSE<OPEN,1) AND CLOSE>REF(XA_117,1),1);
XA_131:=XA_125 OR (BETWEEN(XA_91,3,5) AND XA_9) AND XA_130 AND XA_127;
XA_132:=BARSLAST(XA_131>0);
XA_133:=REF(XA_132,1)+1;
XA_134:=LLV(MIN(CLOSE,OPEN),XA_133);
XA_135:=XA_134>=REF(LOW,XA_133);
XA_136:=COUNT(XA_131>0,13)=2;
XA_137:=REF(OPEN,XA_133);
XA_138:=ABS(OPEN-XA_137)/XA_137<10/100;
XA_139:=1*(XA_131 AND XA_136 AND XA_138 AND REF(XA_135,1) AND BETWEEN(XA_133,4,13));
XA_140:=(MIN(OPEN,CLOSE)-LOW)/CLOSE>=0.02 AND (MIN(OPEN,CLOSE)-LOW)/(HIGH-LOW)>0.5>=0.02;
XA_141:=REF((HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW),1)>0.5 AND REF((HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW),1)>0.5 AND XA_140 AND HIGH<REF(HIGH,1) AND VOL<REF(VOL,1)*1;
XA_142:=3;
XA_143:=3;
XA_144:=HHV(HIGH,240)-LLV(LOW,240);
XA_145:=IF(XA_144<=1,0,IF(XA_144<=5,0.02,2.5/1000*XA_144)+0.005);
XA_146:=VOL>=REF(VOL,1)*1.1 OR CLOSE>OPEN*IF(CLOSE<500,1.03,1.01);
XA_147:=REFX(LLV(LOW,XA_143),XA_143);
XA_148:=XA_146 AND LOW<=XA_147;
XA_149:=REF(HHV(HIGH,XA_142),1);
XA_150:=REF(HHV(MAX(CLOSE,OPEN),XA_142),1);
XA_151:=XA_148 AND ABS(XA_149-XA_147)<=XA_145;
XA_152:=XA_148 AND ABS(XA_150-XA_147)<=XA_145;
XA_153:=REFX(LLV(MIN(CLOSE,OPEN),XA_143),XA_143);
XA_154:=XA_146 AND LOW<=XA_153;
XA_155:=XA_154 AND ABS(XA_149-XA_153)<=XA_145;
XA_156:=XA_154 AND ABS(XA_150-XA_153)<=XA_145;
XA_157:=XA_151 OR XA_152 OR XA_155 OR XA_156;
XA_158:=LOW<OPEN*0.96 AND XA_10 AND MA(CLOSE,60)<=REF(MA(CLOSE,60),1);
XA_159:=BARSLAST(XA_158);
XA_160:=REF(OPEN,XA_159)>=HHV(MAX(CLOSE,OPEN),XA_159) AND REF(LOW,XA_159)<=1.01*LLV(MIN(CLOSE,OPEN),XA_159);
XA_161:=XA_160 AND XA_159>=5 AND MA(VOL,5)<MA(VOL,60);
XA_162:=XA_67 AND ABS(XA_69-REF(XA_69,1))<=XA_70 AND REF(XA_68,1)>=5;
XA_163:=XA_67 AND ABS(XA_69-REF(XA_65,XA_64+1))<=XA_70;
XA_164:=BETWEEN(XA_40,XA_65*0.995,XA_65*1.001);
XA_165:=COUNT(XA_164,10)>=3 AND HHV(HIGH,XA_64)<=XA_65*1.001;
XA_166:=IF(COUNT(XA_33,M周期内),1,0);
XA_167:=IF(COUNT(XA_8,M周期内),1,0);
XA_168:=IF(COUNT(XA_17,M周期内),1,0);
XA_169:=IF(COUNT(XA_20,M周期内),1,0);
XA_170:=IF(COUNT(XA_22,M周期内),1,0);
XA_171:=IF(COUNT(XA_63,M周期内),1,0);
XA_172:=IF(COUNT(XA_90,M周期内),1,0);
XA_173:=IF(COUNT(XA_72,M周期内),1,0);
XA_174:=IF(COUNT(XA_73 AND CLOSE>LOW,M周期内),1,0);
XA_175:=IF(COUNT(XA_161,M周期内),1,0);
XA_176:=IF(COUNT(XA_82,M周期内),1,0);
XA_177:=IF(COUNT(XA_38,M周期内),1,0);
XA_178:=IF(COUNT(XA_141,M周期内),1,0);
XA_179:=IF(COUNT(XA_87,M周期内),1,0);
XA_180:=IF(COUNT(XA_88,M周期内),1,0);
XA_181:=IF(COUNT(XA_157,M周期内)>=1,1,0);
XA_182:=IF(COUNT(XA_162 OR XA_163,M周期内),1,0);
XA_183:=IF(COUNT(XA_94,M周期内),1,0);
XA_184:=IF(COUNT(XA_104,M周期内),1,0);
XA_185:=IF(COUNT(XA_99,M周期内),1,0);
XA_186:=IF(COUNT(XA_100,M周期内),1,0);
XA_187:=IF(COUNT(XA_165,M周期内),1,0);
XA_188:=IF(COUNT(XA_115,M周期内),1,0);
XA_189:=IF(COUNT(XA_123,M周期内),1,0);
XA_190:=IF(COUNT(XA_139,M周期内),1,0);
XA_191:=XA_166+XA_167+XA_168+XA_169+XA_170+XA_171+XA_172+XA_173+XA_174+XA_175+XA_176+XA_178+XA_179+XA_180+XA_177+XA_181+XA_182+XA_183+XA_185+XA_184+XA_186+XA_187+XA_188+XA_189+XA_190;
XA_192:=IF(BARSCOUNT(CLOSE)>=M周期内,XA_191,0);
XA_193:=XA_192;
XG:IF(等于或大于=0,XA_193=N个基因,XA_193>=N个基因) AND DYNAINFO(8)>0;

原创文章,作者:股神,如若转载,请注明出处:http://www.gupiaoxuexi.com/post/28035

发表评论

登录后才能评论