1. 首页
  2. 股票公式

通达信均量画矩形指标公式

通达信均量画矩形指标公式

VM:=11;N:=11;
TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,240,1)))));
MTIME:=MOD(FROMOPEN,TOTAL);
CTIME:=IF(MTIME<0.5,TOTAL,MTIME);
VVOL:IF(CURRBARSCOUNT=1,VOL*TOTAL/CTIME,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 && (SETCODE=0 || SETCODE=1),VVOL,0,-1,-1),COLOR00C0C0;
VOLUME:VOL,VOLSTICK;
V5:=MA(V,VM);
T:=ALIGNRIGHT(MOD(CURRBARSCOUNT,N));
HH:=HHV(V5,N);
STICKLINE(T=1,0,HH,0,0),COLORYELLOW;
STICKLINE(T=0,0,REFX(HH,BARSNEXT(T=1)),0,0),COLORYELLOW;
DRAWLINE(T=0,REFX(HH,BARSNEXT(T=1)),T=1,HH,0),COLORYELLOW;
DRAWLINE(T=1,HH,T=0,REFX(HH,BARSNEXT(T=1)),0),COLORBLACK;
VM1:=22;N1:=22;
VM5:=MA(V,VM1);
T1:=ALIGNRIGHT(MOD(CURRBARSCOUNT,N1));
HH1:=HHV(V5,N1);
STICKLINE(T1=1,0,HH1,0,0),COLORYELLOW;
STICKLINE(T1=0,0,REFX(HH1,BARSNEXT(T1=1)),0,0),COLORWHITE;
DRAWLINE(T1=0,REFX(HH1,BARSNEXT(T1=1)),T1=1,HH1,0),COLORWHITE;
DRAWLINE(T1=1,HH1,T1=0,REFX(HH1,BARSNEXT(T1=1)),0),COLORBLACK;
两倍量:=SUM(V>REF(V,1)*1.9,5)=2;
STICKLINE(两倍量,0,VOL,0.7,30),COLORMAGENTA;
倍量:=VOL/REF(VOL,1)>=1.9;
STICKLINE(倍量,0,VOL,1,0),COLORFF00FF;
STICKLINE(倍量,0,VOL*2/3,1.5,0),COLORFF0000;
STICKLINE(倍量,0,VOL/2,2,0),COLOR00FFFF;
STICKLINE(倍量,0,VOL/3,2.5,0),COLOR00FF00;
STICKLINE(倍量,0,VOL/4,3,0),COLORFFFFFF;

原创文章,作者:股神,如若转载,请注明出处:http://www.gupiaoxuexi.com/post/30491

发表评论

登录后才能评论