1. 首页
  2. 股票公式

通达信七指金叉指标公式

通达信七指金叉指标公式

N1:=3;
N2:=6;
DRAWGBK(CURRBARSCOUNT=1, RGB(0,0,0),RGB(0,0,0),0,’1′,0);
VAR1:=EMA(EMA(CLOSE,9),9);
VAR2:=100*WINNER(CLOSE*0.95);
EXPJX:=EMA(C,12)>EMA(C,50) AND EMA(C,20)>EMA(C,120);
KP:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
GDKP:=VAR2>=50 AND COST(85)<=CLOSE AND KP>0 AND KP>REF(KP,1);
X1:=GDKP AND EXPJX AND REF(GDKP+EXPJX<=1,1);
X2:=MACD.DIF>MACD.DEA AND REF(MACD.DIF<=MACD.DEA OR MACD.DIF<=0,1);
X3:=CLOSE>SAR.SAR AND REF(CLOSE<=SAR.SAR,1);
X4:=RSI.RSI1>RSI.RSI2 AND RSI.RSI2>49 AND REF(COUNT(RSI.RSI1>RSI.RSI2 AND RSI.RSI2>49,1)=0,1);
X5:=CCI.CCI>=100 AND REF(CCI.CCI<100,1);
X6:=KDJ.K>KDJ.D AND REF(KDJ.K<=KDJ.D,1);
X7:=CJDX.K>CJDX.D AND CJDX.K>0 AND REF(COUNT(CJDX.K>CJDX.D AND CJDX.K>0,1)=0,1);
STICKLINE(GDKP AND EXPJX,0,2,4,0),COLORMAGENTA,LINETHICK2;
STICKLINE(GDKP+EXPJX<=1,0,2,4,0),COLORGREEN,LINETHICK2;
DRAWTEXT(ISLASTBAR=1,1,’ 筹码’),COLORFFFFFF;
STICKLINE(CCI.CCI>=100,3,5,4,0),COLORMAGENTA,LINETHICK2;
STICKLINE(CCI.CCI<100,3,5,4,0),COLORGREEN,LINETHICK2;
DRAWTEXT(ISLASTBAR=1,4,’ CCI’),COLORFFFFFF;
STICKLINE(MACD.DIF>MACD.DEA AND MACD.DIF>0,6,8,4,0),COLORMAGENTA,LINETHICK2;
STICKLINE(MACD.DIF<=MACD.DEA OR MACD.DIF<=0,6,8,4,0),COLORGREEN,LINETHICK2;
DRAWTEXT(ISLASTBAR=1,7,’ MACD’),COLORFFFFFF;
STICKLINE(CLOSE>SAR.SAR,9,11,4,0),COLORMAGENTA,LINETHICK2;
STICKLINE(CLOSE<=SAR.SAR,9,11,4,0),COLORGREEN,LINETHICK2;
DRAWTEXT(ISLASTBAR=1,10,’ SAR’),COLORFFFFFF;
STICKLINE(RSI.RSI1>RSI.RSI2 AND RSI.RSI2>49,12,14,4,0),COLORMAGENTA,LINETHICK2;
STICKLINE(COUNT(RSI.RSI1>RSI.RSI2 AND RSI.RSI2>49,1)=0,12,14,4,0),COLORGREEN,LINETHICK2;
DRAWTEXT(ISLASTBAR=1,13,’ RSI’),COLORFFFFFF;
STICKLINE(KDJ.K>KDJ.D,15,17,4,0),COLORMAGENTA,LINETHICK2;
STICKLINE(KDJ.K<=KDJ.D,15,17,4,0),COLORGREEN,LINETHICK2;
DRAWTEXT(ISLASTBAR=1,16,’ KDJ’),COLORFFFFFF;
STICKLINE(CJDX.K>CJDX.D AND CJDX.K>0,18,20,4,0),COLORMAGENTA,LINETHICK2;
STICKLINE(COUNT(CJDX.K>CJDX.D AND CJDX.K>0,1)=0,18,20,4,0),COLORGREEN,LINETHICK2;
DRAWTEXT(ISLASTBAR=1,19,’ CJDX’),COLORFFFFFF;
XM:=X1+X2+X3+X4+X5+X6+X7>=N1;
Y0:=ZIG(3,5);
Y1:=GDKP AND EXPJX;
Y2:=MACD.DIF>MACD.DEA AND MACD.DIF>0 ;
Y3:=CLOSE>SAR.SAR ;
Y4:=RSI.RSI1>RSI.RSI2 AND RSI.RSI1>RSI.RSI3 AND RSI.RSI2>49 ;
Y5:=CCI.CCI>=100 ;
Y6:=KDJ.K>KDJ.D;
Y7:=CJDX.K>CJDX.D AND CJDX.K>0 ;
YM:=Y1+Y2+Y3+Y4+Y5+Y6+Y7>=N2;
STICKLINE(XM AND YM AND GDKP,0,20,3.2,0),COLORRED;
STICKLINE(XM AND YM AND GDKP AND C/REF(C,1)>1.09,0,20,3,0),COLORYELLOW;
STICKLINE(XM AND YM AND GDKP AND C/REF(C,1)>1.09,0,20,1,0),COLORRED;

原创文章,作者:股神,如若转载,请注明出处:http://www.gupiaoxuexi.com/post/30535

发表评论

登录后才能评论