1. 首页
  2. 股票公式

通达信百万股神擒牛主图指标公式

通达信百万股神擒牛主图指标公式

回归斜率线A:=EMA(SLOPE(C,4)20+C,42); 经典RL:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))100;
经典K:=SMA(经典RL,3,1);经典D:=SMA(经典K,3,1);经典J:=3经典K-2经典D;
MAHL1:=100*((EMA((H+L)/2,3)-LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-EMA(L,20)))/(LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-EMA(L,20))));
MAHL2:=IF(EMA(C,2)>回归斜率线AANDMAHL1>0,EMA(C,3),LLV(EMA((H+L)/2,5),30));{A}
MAHL3:=IF(EMA(C,2)>回归斜率线AANDMAHL1>0,LLV(EMA((H+L)/2,5),30),EMA(C,5));{A}

回归斜率带:DRAWBAND(回归斜率线A,RGB(235,0,230),REF(回归斜率线A,2),RGB(0,104,154));

上线:=SMA(C,6.5,1);
一号支撑线:SMA(C,14.5,1);
上线1:=SMA(C,3,1);
一号支撑线1:=SMA(C,8,1);
上线2:=SMA(C,3.5,1);
DRAWTEXT(CROSS(一号支撑线1,上线1),H1.08,’洗盘’),COLOR00FF00; BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,25))/4; UPR:=BBI+3STD(BBI,13),LINETHICK2;
DWN:=BBI-3STD(BBI,13); 安全:=MA(CLOSE,55),LINETHICK2; LC:=REF(CLOSE,1); RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)100;
DRAWTEXT(CROSS(82,RSI)ANDCLOSE<上线1,HIGH1.04,’减仓’),COLORFF9966,LINETHICK2; A7:=(2C+H+L)/4;
操作:MA(A7,5),COLORBLUE,LINETHICK2;
操作1:=MA(A7,5)1.03,LINETHICK2; 操作2:=MA(A7,5)0.97,LINETHICK2;

DRAWTEXT(CROSS(上线1,上线)AND上线1>操作,LOW0.92,’买进’),COLORYELLOW; VAR1:LLV(A7,21); VAR2:HHV(A7,30); DRAWTEXT(CROSS(上线1,操作)AND上线1<一号支撑线AND上线1<一号支撑线1AND上线1<上线ANDCLOSE>VAR1,LOW0.98,’见底’),COLORYELLOW;
YCX:=操作>=REF(操作,1);
H1:=MAX(MAX(上线,一号支撑线1),一号支撑线);
L1:=MIN(MIN(上线,一号支撑线1),一号支撑线);
DRAWTEXT(CROSS(上线1,一号支撑线1)AND上线1>操作,LOW0.98,’全仓’),COLORYELLOW; SK:=EMA((A7-VAR1)/(VAR2-VAR1)100,7);
SD:=EMA(0.667REF(SK,1)+0.333SK,5);
M1:=1000操作/一号支撑线<=1015AND1000操作/一号支撑线>=975;
M2:=1000一号支撑线1/一号支撑线<=1020AND一号支撑线1/一号支撑线>=980; M3:=1000上线/一号支撑线<=1015AND上线/一号支撑线>=985;
DRAWTEXT(IF(COUNT(CLOSE6/10AND
COUNT(SK>SD,6)ANDREF(LOW,5)=LLV(LOW,120)ANDREF(CLOSE>=OPEN,4)AND
REF(CLOSE>OPEN,3)ANDREF(CLOSE>OPEN,2)ANDREF(OPEN>CLOSE,1)AND
OPEN>REF(CLOSE,1),1,0),LOW0.94,’买进’),COLORYELLOW; D:=MA(CLOSE,89)-MA(CLOSE,10)/3; DRAWTEXT(IF(CLOSEMA(VOL,5)/240ANDCLOSE>REF(CLOSE,1)1.08
ANDCLOSE<MA(CLOSE,13)1.3,1,0),LOW0.88,’抄底’),COLORBROWN;
RSV:=(CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))100; K:=SMA(RSV,3,1); D1:=SMA(K,3,1); J:=3K-2D1; VAR3:=(2CLOSE+HIGH+LOW)/3;{可将3该为4,信号少点}
VAR4:=EMA(EMA(EMA(VAR3,4),4),4);{可将3该为4,信号少点}
E:=(VAR4-REF(VAR4,1))/REF(VAR4,1)*100;
F:=MA(E,3)+0.03;
G:=MA(E,1);

DRAWICON(CROSS(F,G)ANDJ>65,HIGH1.02,15),COLORGREEN; DRAWICON(CROSS(G,F),LOW0.9,9),COLORYELLOW;

DRAWTEXT(CLOSE>OPENANDH1VAR1AND上线1>一号支撑线ANDJ<90,LOW*0.9,’主升’),COLORRED;

DRAWTEXT(CROSS(上线1,操作)ANDM1ANDM2ANDM3,LOW0.94,’买进’),COLORYELLOW; DRAWTEXT(CLOSE>OPENAND上线>一号支撑线1AND一号支撑线1>一号支撑线ANDCLOSE>MA(CLOSE,一号支撑线)AND操作>=REF(CLOSE,操作)ANDCROSS(上线1,操作)ANDLOW>VAR1ANDJ<90,LOW0.9,’主升’),COLORRED;
DRAWTEXT(CLOSE>OPENAND操作>上线AND上线>一号支撑线1AND一号支撑线1>一号支撑线ANDCROSS(上线1,操作)ANDLOW>VAR1ANDJ<90,LOW0.86,’回踩买进’),COLORRED; DRAWTEXT(CLOSE>OPENANDCROSS(上线,一号支撑线)ANDLOW>VAR1ANDJ<90,LOW0.86,’回踩买进’),COLORRED;

STICKLINE(CLOSE>REF(CLOSE,1),HIGH,LOW,0,0),COLORRED;
STICKLINE(CREF(C,1),C,O,3,0),COLORFFCC00;
STICKLINE(CLOSE>REF(CLOSE,1)ANDC>O,OPEN,CLOSE,3,0),COLOR000055;{红K};
STICKLINE(CLOSE>REF(CLOSE,1)ANDC>O,OPEN,CLOSE,2.7,0),COLOR000077;{红K};
STICKLINE(CLOSE>REF(CLOSE,1)ANDC>O,OPEN,CLOSE,2.1,0),COLOR000099;
STICKLINE(CLOSE>REF(CLOSE,1),OPEN,CLOSE,1.5,0),COLOR0000BB;
STICKLINE(CLOSE>REF(CLOSE,1),OPEN,CLOSE,0.9,0),COLOR0000DD;
STICKLINE(CLOSE>REF(CLOSE,1),OPEN,CLOSE,0.3,0),COLOR0000FF;
STICKLINE(CLOSE=REF(CLOSE,1),H,L,3,1),COLOR999999;
STICKLINE(CLOSE=REF(CLOSE,1),HIGH,LOW,0,0),COLORWHITE;
STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,3,0),COLOR555555;
STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,2.7,0),COLOR777777;
STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,2.1,0),COLOR999999;
STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,1.5,0),COLORBBBBBB;
STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,0.9,0),COLORDDDDDD;
STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,0.3,0),COLORFFFFFF;
STICKLINE(CLOSEO,C,O,3,0),COLORFFCC00;
STICKLINE(C<REF(C,1)ANDC<O,OPEN,CLOSE,3,0),COLOR990000;
STICKLINE(C<REF(C,1)ANDC<O,OPEN,CLOSE,2.7,0),COLORCC0000;
STICKLINE(CLOSE<REF(C,1),OPEN,CLOSE,2.1,0),COLORFF4400;
STICKLINE(CLOSE<REF(C,1),OPEN,CLOSE,1.5,0),COLORFF8800;
STICKLINE(CLOSE<REF(C,1),OPEN,CLOSE,0.9,0),COLORFFCC00;
STICKLINE(CROSS(J,D1)ANDJ<70,CLOSE,OPEN,3.2,0),COLORBB00FF;
STICKLINE(CROSS(J,D1)ANDJ<70,CLOSE,OPEN,2.7,0),COLORFF33FF;
STICKLINE(CROSS(J,D1)ANDJ<70,CLOSE,OPEN,2.1,0),COLORFF66FF;
STICKLINE(CROSS(J,D1)ANDJ<70,CLOSE,OPEN,1.5,0),COLORFF99FF;
STICKLINE(CROSS(J,D1)ANDJ<70,CLOSE,OPEN,0.9,0),COLORFFBBFF;
STICKLINE(CROSS(J,D1)ANDJ<70,CLOSE,OPEN,0.3,0),COLORFFDDFF;

原创文章,作者:股神,如若转载,请注明出处:http://www.gupiaoxuexi.com/post/38088

发表评论

登录后才能评论