1. 首页
  2. 股票公式

通达信逃顶王主图指标公式

通达信逃顶王主图指标公式

O1:(SUM(EMA((CLOSE+LOW)/2,1)/3,3)),COLOR00FFFF,LINETHICK1;
O2:EMA(O1,3),COLORFF00FF,LINETHICK1;
O3:EMA(O2,3),COLOR00FF00,LINETHICK1;
MMM:=MA(CLOSE,20);
DRAWTEXT((CLOSE’),COLOR00FF00,LINETHICK5; DRAWTEXT((CLOSE>MMM),MMM,”),COLOR0000FF,LINETHICK5; VAR1:=CLOSE>REF(CLOSE,1)ANDCLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1)ANDCLOSE<=REF(CLOSE,1)ANDCLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1)ANDCLOSE>=REF(CLOSE,1)ANDCLOSE<=REF(CLOSE,2); VAR4:=REF(VAR3,1)ANDCLOSE<=REF(CLOSE,1)ANDCLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1)ANDCLOSE>=REF(CLOSE,1)ANDCLOSE<=REF(CLOSE,2); VAR6:=REF(VAR5,1)ANDCLOSE<=REF(CLOSE,1)ANDCLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1)ANDCLOSE>=REF(CLOSE,1)ANDCLOSE<=REF(CLOSE,2); VAR8:=REF(VAR7,1)ANDCLOSE<=REF(CLOSE,1)ANDCLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1)ANDCLOSE>=REF(CLOSE,1)ANDCLOSE<=REF(CLOSE,2); VARA:=REF(VAR9,1)ANDCLOSE<=REF(CLOSE,1)ANDCLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1)ANDCLOSE>=REF(CLOSE,1)ANDCLOSE<=REF(CLOSE,2); VARC:=REF(VARB,1)ANDCLOSE<=REF(CLOSE,1)ANDCLOSE>=REF(CLOSE,2);
VARD:=CLOSE=REF(CLOSE,1)ANDCLOSE<=REF(CLOSE,2); VARF:=REF(VARE,1)ANDCLOSE<=REF(CLOSE,1)ANDCLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1)ANDCLOSE>=REF(CLOSE,1)ANDCLOSE<=REF(CLOSE,2); VAR11:=REF(VAR10,1)ANDCLOSE<=REF(CLOSE,1)ANDCLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1)ANDCLOSE>=REF(CLOSE,1)ANDCLOSE<=REF(CLOSE,2); VAR13:=REF(VAR12,1)ANDCLOSE<=REF(CLOSE,1)ANDCLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1)ANDCLOSE>=REF(CLOSE,1)ANDCLOSE<=REF(CLOSE,2); VAR15:=REF(VAR14,1)ANDCLOSE<=REF(CLOSE,1)ANDCLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1)ANDCLOSE>=REF(CLOSE,1)ANDCLOSE<=REF(CLOSE,2); VAR17:=REF(VAR16,1)ANDCLOSE<=REF(CLOSE,1)ANDCLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1)ANDCLOSE>=REF(CLOSE,1)ANDCLOSE<=REF(CLOSE,2);
VAR19:=REF(VARDORVAREORVARFORVAR10ORVAR11ORVAR12ORVAR13OR
VAR14ORVAR15ORVAR16ORVAR17ORVAR18,1)ANDVAR1;
VAR1A:=REF(VAR1ORVAR2ORVAR3ORVAR4ORVAR5ORVAR6ORVAR7OR
VAR8ORVAR9ORVARAORVARBORVARC,1)ANDVARD;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3.2,0),COLORFF3300;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2.7,0),COLORFF5500;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2.1,0),COLORFF7700;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),1.5,0),COLORFF9900;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),0.9,0),COLORFFBB00;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),0.3,0),COLORFFDD00;
DRAWTEXT(FILTER(VAR19=1,5),LOW,’买进’),COLORFF00FF;
DRAWICON(FILTER(VAR19=1,5),LOW,9);
DRAWTEXT(FILTER(VAR1A=1,5),HIGH,’逃顶’),COLOR00FF00;
DRAWICON(FILTER(VAR1A=1,5),HIGH,15);

原创文章,作者:股神,如若转载,请注明出处:http://www.gupiaoxuexi.com/post/38238

发表评论

登录后才能评论