1. 首页
  2. 股票公式

通达信操盘线CPX主图指标公式

通达信操盘线CPX主图指标公式

{CPX操盘线}
bu:=cross(high,SAR(3,1,20));
sel:=cross(SAR(3,1,20),low);

var1:=last(highsar(3,1,20));

drawflagtext(bu,high,’买入’);
drawflagtext(sel,low,’卖出’);

drawtext(bu,LOW,’B’),valign0,align1,coloryellow,linethick2;
drawtext(sel,HIGH,’S’),valign2,align1,colorgreen,linethick2;

STICKLINE(low>SAR(3,1,20) and isdown,high,open,0.5,1),colorred;
STICKLINE(low>SAR(3,1,20) and isdown,close,open,7.5,1),colorred;
STICKLINE(low>SAR(3,1,20) and isdown,close,low,0.5,1),colorred;

STICKLINE(high<SAR(3,1,20) and isup,high,close,0.5,1),colorcyan;
STICKLINE(high<SAR(3,1,20) and isup,close,open,7.5,1),colorcyan;
STICKLINE(high<SAR(3,1,20) and isup,open,low,0.5,1),colorcyan;

drawflagtext(high=ref(high,1),high,’明日突破’+forcast(sar(3,1,20),max(var1,2))+’建议关注’);
drawflagtext(high<SAR(3,1,20) and high<ref(high,1),high,’持币观望’);

drawflagtext(low>SAR(3,1,20) and low<=ref(low,1),low,’明日跌破’+forcast(sar(3,1,20),max(var2,2))+’注意止盈’); drawflagtext(low>SAR(3,1,20) and low>ref(low,1),low,’继续持股’);

{DPCW大盘仓位}
Ms5:=SMA(MA(C,2),5,3);
Ms13:=SMA(C,13,2);
Ms21:=SMA(C,21,1);
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
a:=SMA(RSV,3,1);
b:=SMA(a,3,1);

DDX:=bigorder(1,2)-bigorder(2,2);
DIFF:=EMA(DDX,6) – EMA(DDX,13);
DIFF2:=EMA(DDX,9) – EMA(DDX,20);

IF(Ms5>REF(Ms5,1)) then
m1:=10;
ELSE IF(Ms5C) then
m2:=-5;
IF(Ms13>REF(Ms13,1)) then
m3:=5;
ELSE IF(Ms13REF(Ms21,1)) then
m4:=10;
ELSE IF(Ms2190) then
m5:=-10;
ELSE IF(b<90 AND b>10) then
m5:=0;
ELSE IF(b<10) then m5:=10; IF(diff>0 AND diff2>0) then
m6:=10;
ELSE IF(diff>0 OR diff2>0) then
m6:=0;
ELSE IF(diff<0 AND diff2<0) then
m6:=-10;

大盘仓位:(m1+m2+m3+m4+m5+m6+50);
STICKLINE(大盘仓位>50,0,大盘仓位,9,1),colorF000FF;
STICKLINE(大盘仓位<=50,0,大盘仓位,9,0),colorgreen;

该公式指标是大智慧今天才正式发布的,一共有7个指标通过收费版软件升级传送,这是其中没公开过的,具体效果要实践中总结才知。B点信号买入,S点卖出;跟以往的类似指标有点不同。而后一个指标主要是仓位的大小控制。
希望能对大家有所帮助!

原创文章,作者:股神,如若转载,请注明出处:http://www.gupiaoxuexi.com/post/38265

发表评论

登录后才能评论