1. 首页
  2. 股票公式

通达信主控战略K线主图指标公式

通达信主控战略K线主图指标公式

平顶:=H=REF(H,1) OR (H=REF(H,2) AND H>REF(H,1));
DRAWTEXT(平顶,H1.01,’←平顶’),COLORMAGENTA; 平底:=L=REF(L,1) OR (L=REF(L,2) AND L0.99,’←平底’),COLORMAGENTA;
阳子母:=C>REF(MAX(C,O),1) AND H>REF(H,1) AND LO AND REF(MAX(C,O),1)/REF(MIN(C,O),1)>1.01 AND (O != L OR C != H);
DRAWTEXT(阳子母,L0.99,’←阳子母’),COLORYELLOW; 阴子母:=CREF(H,1) AND L1.01 AND (O != H OR C != L); DRAWTEXT(阴子母,H1.01,’←阴子母’),COLORRED;
阴母子:=C>REF(MIN(C,O),1) AND HREF(L,1) AND CREF(L,1) AND C>O AND C/O>1.01;
DRAWTEXT(阳母子,L0.99,’←阳母子’),COLORYELLOW; 乌云盖顶:=REF(C,1)/REF(O,1)>1.03 AND CREF(H,1) AND C>REF(O,1) AND L>REF(L,1) AND O>REF(H,1) AND C<(REF(C,1)+REF(O,1))/2; DRAWTEXT(乌云盖顶,H1.01,’←乌云盖顶’),COLORMAGENTA;
曙光初现:=REF(O,1)/REF(C,1)>1.03 AND C>O AND H(REF(C,1)+REF(O,1))/2;
DRAWTEXT(曙光初现,L0.99,’←曙光初现’),COLORYELLOW; 空戳多:=C1.03 AND CREF(H,1) AND C>REF(O,1) AND L>REF(L,1) AND O>REF(H,1) AND C>(REF(C,1)+REF(O,1))/2; DRAWTEXT(空戳多,H1.01,’←空戳多’),COLORRED;
多戳空:=C>REF(C,1) AND REF(O,1)/REF(C,1)>1.03 AND C>O AND H0.99,’←多戳空’),COLORYELLOW; 空头反攻:=C=REF(C,1) AND REF(C,1)/REF(O,1)>1.03 AND CREF(H,1) AND C>REF(O,1) AND L>REF(L,1) AND O>REF(H,1); DRAWTEXT(空头反攻,H
1.01,’←空头反攻’),COLORBLUE; 多头反攻:=C=REF(C,1) AND REF(O,1)/REF(C,1)>1.03 AND C>O AND H0.99,’←多头反攻’),COLORYELLOW; 玉柱:=C>REF(MAX(C,O),1) AND H>REF(H,1) AND LO AND REF(MAX(C,O),1)/REF(MIN(C,O),1)>1.01 AND O=L AND C=H; DRAWTEXT(玉柱,L0.99,’←玉柱’),COLORYELLOW; 危楼:=CREF(H,1) AND L1.01 AND O=H AND C=L;
DRAWTEXT(危楼,H1.01,’←危楼’),COLORBLUE; {3根K线组合} 红三兵:=COUNT(H/C<1.02,3)=3 AND COUNT(C/O>1.01,3)=3 AND COUNT(C>REF(C,1),2)=2 AND COUNT(H>REF(H,1),2)=2 AND COUNT(L>REF(L,1),2)=2 AND ABS(REF(C,2)/REF(O,2)-REF(C,1)/REF(O,1))<0.02 AND ABS(REF(C,1)/REF(O,1)-C/O)<0.02; DRAWTEXT(红三兵,L0.99,’←红三兵’),COLORYELLOW;
黑三兵:=COUNT(C/L<1.02,3)=3 AND COUNT(O/C>1.01,3)=3 AND COUNT(C1.01,’←黑三兵’),COLORMAGENTA; 大敌当前:=COUNT(C/O<1.03,2)=2 AND COUNT(H/C>1.015,2)=2 AND COUNT(C>O,3)=3 AND COUNT(C>REF(C,1),2)=2 AND COUNT(H>REF(H,1),2)=2 AND COUNT(L>REF(L,1),2)=2 AND REF(C,2)/REF(O,2)>1.03 AND REF(C,2)/REF(O,2)>REF(C,1)/REF(O,1) AND REF(C,2)/REF(O,2)>C/O AND H/C>REF(H/C,2) AND REF(H/C,1)>REF(H/C,2); DRAWTEXT(大敌当前,L0.99,’←大敌当前’),COLORBLUE; 步步为营:=COUNT(C>O,3)=3 AND COUNT(C>REF(C,1),2)=2 AND COUNT(H>REF(H,1),2)=2 AND COUNT(L>REF(L,1),2)=2 AND (REF(C/O,2)>1.03 OR REF(C/O,1)>1.03) AND C/OREF(H/C,2) AND H/C>REF(H/C,1)) AND H/C>1.02;
DRAWTEXT(步步为营,L0.99,’←步步为营’),COLORRED; 离黑战车:=REF(C/O,2)>1.01 AND REF(O/C,1)>1.01 AND C/O>1.01 AND REF(H/C,2)<1.02 AND REF(H/O,1)<1.02 AND H/C<1.02 AND REF(O,1)>REF(C,2) AND C>REF(O,1) AND COUNT(H>REF(H,1),2)=2 AND COUNT(L>REF(L,1),2)=2 AND ABS(REF(C/O,2)-REF(O/C,1))<0.02 AND ABS(REF(O/C,1)-C/O)<0.02 AND REF(C,1)>REF(O,2); DRAWTEXT(离黑战车,L0.99,’←离黑战车’),COLORYELLOW;
离白战车:=REF(O/C,2)>1.01 AND REF(C/O,1)>1.01 AND O/C>1.01 AND REF(H/O,2)<1.02 AND REF(H/C,1)<1.02 AND H/O<1.02 AND (REF(C,1)=REF(O,2) OR REF(C,1)1.01,’←离白战车’),COLORMAGENTA; 晨星:=(REF(C/O,2)<0.97 AND ABS(REF(C/O,1)-1)<0.015 AND C/O>1.025 AND REF(MAX(C,O),1)REF(MAX(C,O),1)) OR (REF(C/O,3)<0.97 AND ABS(REF(C/O,1)-1)<0.02 AND ABS(REF(C/O,2)-1)<0.02 AND C/O>1.025 AND REF(MAX(C,O),2)REF(MAX(C,O),1) AND O>REF(MAX(C,O),2)); DRAWTEXT(晨星,L0.99,’←晨星’),COLORYELLOW; 夜星:=(REF(O/C,2)<0.97 AND ABS(REF(C/O,1)-1)<0.015 AND O/C>1.025 AND REF(MIN(C,O),1)>REF(C,2) AND O1.025 AND REF(MIN(C,O),2)>REF(C,3) AND REF(MIN(C,O),1)>REF(C,3) AND O1.01,’←夜星’),COLORBLUE; 双鸦:=REF(C/O,2)>1.03 AND REF(O/C,1)-1<0.015 AND REF(C,1)>REF(C,2) AND REF(O,1)>REF(C,2) AND O/C>1.025 AND OREF(C,1) AND H1.01,’←双鸦’),COLORBLUE; 双鸦耀空:=REF(C/O,2)>1.03 AND REF(O/C,1)<1.015 AND O/C<1.015 AND REF(C,1)>REF(C,2) AND C>REF(C,2) AND CREF(MA(C,10),1),13)>10 AND REF(C/O,2)>1.03 AND REF(C/O,1)>1.02 AND REF(L,1)>REF(H,2) AND H1.02 AND C>REF(H,2);
DRAWTEXT(上肩缺口,L0.99,’←上肩缺口’),COLORYELLOW; 下肩缺口:=REF(L,1)=REF(LLV(L,20),1) AND COUNT(MA(C,10)10 AND REF(O/C,2)>1.03 AND REF(O/C,1)>1 AND REF(H,1)REF(L,1) AND C>REF(O,1) AND H>REF(H,1) AND O>REF(C,1) AND C/O>1.02 AND C1.01,’←下肩缺口’),COLORBLUE;
{4根K线组合}
上扬三法:=REF(C/O,3)>1.03 AND REF(H,2)>REF(H,3) AND REF(C,2)REF(C,3) AND REF(H,1)REF(O,3) AND COUNT(O/C>1.03,3)<2 AND COUNT(O/C>1.01,3)>1 AND COUNT(C0.99,’←上扬三法’),COLORYELLOW; 下跌三法:=REF(O/C,3)>1.03 AND REF(L,2)REF(C,3) AND REF(O,2)REF(H,2) AND REF(L,1)>REF(L,2) AND H>REF(H,1) AND L>REF(L,1) AND REF(C,1)>REF(C,2) AND C>REF(C,1) AND H1.03,3)<2 AND COUNT(C/O>1.01,3)>1 AND COUNT(C>O,3)=3; DRAWTEXT(下跌三法,H
1.01,’←下跌三法’),COLORBLUE; 宝塔翻白:=REF(COUNT(C>REF(C,1),3),1)=0 AND REF(COUNT(CREF(HHV(H,3),1) AND C>REF(HHV(C,3),1);
DRAWTEXT(宝塔翻白,L0.99,’←宝塔翻白’),COLORYELLOW; 宝塔翻黑:=REF(COUNT(CO,3),1)=3 AND H>REF(H,1) AND O>REF(C,1) AND L1.01,’←宝塔翻黑’),COLORBLUE;
{多根K线组合}
离黑:=MA(C,13)>REF(MA(C,13),1) AND REF(COUNT(HHV(C,10)/LLV(O,10)<1.15,10),1)=10 AND O/REF(MAX(C,O),1)>1.01 AND C/REF(H,1)>1.05 AND H=HHV(H,15) AND H/C<1.02;
DRAWTEXT(离黑,L0.99,’←离黑’),COLORYELLOW; 离白:=MA(C,13)1.01,’←离白’),COLORMAGENTA;

原创文章,作者:股神,如若转载,请注明出处:http://www.gupiaoxuexi.com/post/40498

发表评论

登录后才能评论