1. 股票学习网首页
  2. 股票公式

通达信布林注解主图指标公式

通达信布林注解主图指标公式

MA3:=MA(C,3);
YTSL:=(3C+L+O+H)/6; 辰星线:(20YTSL+19REF(YTSL,1)+18REF(YTSL,2)+17REF(YTSL,3)+16REF(YTSL,4)+15REF(YTSL,5)+14REF(YTSL,6)+13REF(YTSL,7)+12REF(YTSL,8)+11REF(YTSL,9)+10REF(YTSL,10)+9REF(YTSL,11)+8REF(YTSL,12)+7REF(YTSL,13)+6REF(YTSL,14)+5REF(YTSL,15)+4REF(YTSL,16)+3REF(YTSL,17)+2REF(YTSL,18)+REF(YTSL,20))/211,COLORFFFF00;
牵牛线:MA(C,26),COLOR669933;
等待:IF(MA3<=辰星线,牵牛线,DRAWNULL),COLORGREEN,LINETHICK2; 中轨:=MA(C,26); 上轨:=中轨+STD(C,20); 下轨:=中轨-STD(C,20); 上极限:(中轨+2STD(C,20)),COLORFF937F,LINETHICK2; 下极限:(中轨-2STD(C,20)),COLORWHITE,LINETHICK2; 急速超跌:=(C-MA(C,34))/MA(C,34)*100<-14; VAR1:=(C>REF(C,1)ANDC>REF(C,2));
VAR2:=(REF(VAR1,1)ANDC<=REF(C,1)ANDC>=REF(C,2));
VAR3:=(REF(VAR2,1)ANDC>=REF(C,1)ANDC<=REF(C,2)); VAR4:=(REF(VAR3,1)ANDC<=REF(C,1)ANDC>=REF(C,2));
VAR5:=(REF(VAR4,1)ANDC>=REF(C,1)ANDC<=REF(C,2)); VAR6:=(REF(VAR5,1)ANDC<=REF(C,1)ANDC>=REF(C,2));
VAR7:=(REF(VAR6,1)ANDC>=REF(C,1)ANDC<=REF(C,2)); VAR8:=(REF(VAR7,1)ANDC<=REF(C,1)ANDC>=REF(C,2));
VAR9:=(REF(VAR8,1)ANDC>=REF(C,1)ANDC<=REF(C,2)); VARA:=(REF(VAR9,1)ANDC<=REF(C,1)ANDC>=REF(C,2));
VARB:=(REF(VARA,1)ANDC>=REF(C,1)ANDC<=REF(C,2)); VARC:=(REF(VARB,1)ANDC<=REF(C,1)ANDC>=REF(C,2));
持股:IF(VAR1ORVAR2ORVAR3ORVAR4ORVAR5ORVAR6ORVAR7ORVAR8ORVAR9ORVARAORVARBORVARC,辰星线,DRAWNULL),COLORRED,POINTDOT,LINETHICK5;
VARD:=(C=REF(C,1)ANDC<=REF(C,2)); VARF:=(REF(VARE,1)ANDC<=REF(C,1)ANDC>=REF(C,2));
VAR10:=(REF(VARF,1)ANDC>=REF(C,1)ANDC<=REF(C,2)); VAR11:=(REF(VAR10,1)ANDC<=REF(C,1)ANDC>=REF(C,2));
VAR12:=(REF(VAR11,1)ANDC>=REF(C,1)ANDC<=REF(C,2)); VAR13:=(REF(VAR12,1)ANDC<=REF(C,1)ANDC>=REF(C,2));
VAR14:=(REF(VAR13,1)ANDC>=REF(C,1)ANDC<=REF(C,2)); VAR15:=(REF(VAR14,1)ANDC<=REF(C,1)ANDC>=REF(C,2));
VAR16:=(REF(VAR15,1)ANDC>=REF(C,1)ANDC<=REF(C,2)); VAR17:=(REF(VAR16,1)ANDC<=REF(C,1)ANDC>=REF(C,2));
VAR18:=(REF(VAR17,1)ANDC>=REF(C,1)ANDC<=REF(C,2));
持币:IF(VARDORVAREORVARFORVAR10ORVAR11ORVAR12ORVAR13ORVAR14ORVAR15ORVAR16ORVAR17ORVAR18,辰星线,DRAWNULL),COLORLIGRAY,POINTDOT,LINETHICK5;
VAR19:=((REF(VARDORVAREORVARFORVAR10ORVAR11ORVAR12ORVAR13ORVAR14ORVAR15ORVAR16ORVAR17ORVAR18,1))ANDVAR1);
VAR1A:=((REF(VAR1ORVAR2ORVAR3ORVAR4ORVAR5ORVAR6ORVAR7ORVAR8ORVAR9ORVARAORVARBORVARC,1))ANDVARD);
DRAWTEXT(VAR19,L,’←短买’),COLOR33FFCC;
DRAWTEXT(VAR1A,H+0.1,’←离场’),COLORFF99FF;

原创文章,作者:股神,如若转载,请注明出处:http://www.gupiaoxuexi.com/post/40545

发表评论

登录后才能评论
Copy Protected by Chetan's WP-Copyprotect.