1. 股票学习网首页
  2. 股票公式

通达信四档红绿灯副图指标公式

通达信四档红绿灯副图指标公式

C15:=C;
A15:=MAX(MA(C15,4),MA(C15,8));
B15:=MIN(MA(C15,4),MA(C15,8));
绿灯行15:C15>A15,COLORGREEN;
红灯停15:C15=C15 AND C15>=B15,COLORYELLOW ;
STICKLINE(C15>A15,17,20,8,0),COLORGREEN,LINETHICK2;
STICKLINE(C15=C15 AND C15>=B15,17,20,8,0),COLORYELLOW,LINETHICK2;
DRAWTEXT(C=C AND CURRBARSCOUNT=100,19,’【15日线】’),COLORBLUE;
C30:=C;
A30:=MAX(MA(C30,8),MA(C30,15));
B30:=MIN(MA(C30,8),MA(C30,15));
绿灯行30:C30>A30,COLORGREEN;
红灯停30:C30=C30 AND C30>=B30,COLORYELLOW ;
STICKLINE(C30>A30,12,15,8,0),COLORGREEN,LINETHICK2;
STICKLINE(C30=C30 AND C30>=B30,12,15,8,0),COLORYELLOW,LINETHICK2;
DRAWTEXT(C=C AND CURRBARSCOUNT=100,14,’【30日线】’),COLORBLUE;
C60:=C;
A60:=MAX(MA(C60,15),MA(C60,30));
B60:=MIN(MA(C60,15),MA(C60,30));
绿灯行60:C60>A60,COLORGREEN;
红灯停60:C60=C60 AND C60>=B60,COLORYELLOW ;
STICKLINE(C60>A60,7,10,8,0),COLORGREEN,LINETHICK2;
STICKLINE(C60=C60 AND C60>=B60,7,10,8,0),COLORYELLOW,LINETHICK2;
DRAWTEXT(C=C AND CURRBARSCOUNT=100,9,’【60日线】’),COLORBLUE;
CC:=C;
A:=MAX(MA(CC,60),MA(CC,120));
B:=MIN(MA(CC,60),MA(CC,120));
绿灯行:C>A,COLORGREEN;
绿灯停:C=C AND C>=B,COLORYELLOW ;
STICKLINE(C>A,2,5,8,0),COLORGREEN,LINETHICK2;
STICKLINE(C=C AND C>=B,2,5,8,0),COLORYELLOW,LINETHICK2;
DRAWTEXT(C=C AND CURRBARSCOUNT=100,4,’【120日线】’),COLORBLUE;

原创文章,作者:股神,如若转载,请注明出处:http://www.gupiaoxuexi.com/post/40561

发表评论

登录后才能评论
Copy Protected by Chetan's WP-Copyprotect.