1. 股票学习网首页
  2. 股票公式

通达信RSIMACD综合副图指标公式

通达信RSIMACD综合副图指标公式

X_1:=EMA(CLOSE,12)-EMA(CLOSE,26);
X_2:=EMA(X_1,9);
X_3:=REF(CLOSE,1);
RSI1:SMA(MAX(CLOSE-X_3,0),6,1)/SMA(ABS(CLOSE-X_3),6,1)100,COLORWHITE; RSI2:SMA(MAX(CLOSE-X_3,0),12,1)/SMA(ABS(CLOSE-X_3),12,1)100,COLORYELLOW;
RSI3:SMA(MAX(CLOSE-X_3,0),24,1)/SMA(ABS(CLOSE-X_3),24,1)*100,COLORMAGENTA;
RSI:RSI1-RSI3,COLORSTICK,LINETHICK2;
X_4:=BARSLAST(REF(CROSS(X_1,X_2),1));
X_5:=REF(CLOSE,X_4+1)>CLOSEANDREF(X_1,X_4+1)CLOSEANDREF(KDJ.K(9,3,3),X_6+1)CLOSEANDREF(RSI.RSI1(6,12,24),X_8+1)X_1ANDCROSS(X_2,X_1);
X_12:=BARSLAST(REF(CROSS(KDJ.D(9,3,3),KDJ.K(9,3,3)),1));
X_13:=REF(CLOSE,X_12+1)KDJ.K(9,3,3)ANDCROSS(KDJ.D(9,3,3),KDJ.K(9,3,3));
X_14:=BARSLAST(REF(CROSS(RSI.RSI2(6,12,24),RSI.RSI1(6,12,24)),1));
X_15:=REF(CLOSE,X_14+1)RSI.RSI1(6,12,24)ANDCROSS(RSI.RSI2(6,12,24),RSI.RSI1(6,12,24));
MACD底背:IF(X_5>0,(-0.1),0),POINTDOT,COLORRED;
KDJ底背:IF(X_7>0,(-0.1),0),POINTDOT,COLORMAGENTA;
RSI底背:IF(X_9>0,(-0.1),0),POINTDOT,COLORYELLOW;
MACD顶背:IF(X_11>0,0.1,0),POINTDOT,COLORGREEN;
KDJ顶背:IF(X_13>0,0.1,0),POINTDOT,COLORFFCC66;
RSI顶背:IF(X_15>0,0.1,0),POINTDOT,COLORWHITE;
STICKLINE(X_5>0,(-25),0,2,0),COLORRED;
STICKLINE(X_7>0,(-25),0,2,0),COLORMAGENTA;
STICKLINE(X_9>0,(-25),0,2,0),COLORYELLOW;
STICKLINE(X_11>0,25,0,2,0),COLORGREEN;
STICKLINE(X_13>0,25,0,2,0),COLORFFCC66;
STICKLINE(X_15>0,25,0,2,0),COLORWHITE;

原创文章,作者:股神,如若转载,请注明出处:http://www.gupiaoxuexi.com/post/40609

发表评论

登录后才能评论
Copy Protected by Chetan's WP-Copyprotect.