同花顺MACD快慢指标公式

AA:=EMA((2C+H+L)/4,3); A1:=SLOPE(AA5-REF(AA,5),5)+C;
DDIF:=EMA(A1,3) – EMA(A1,13);
DDEA:=EMA(DDIF,3);
K线动能:=(DDIF-DDEA)50; STICKLINE((K线动能 > 1),0,K线动能,2,0),coloryellow; STICKLINE((K线动能 > 1),0,K线动能0.9,2,0),coloryellow;
STICKLINE((K线动能 > 1),0,K线动能0.8,2,0),coloryellow; STICKLINE((K线动能 > 1),0,K线动能0.7,2,0),colorlired;
STICKLINE((K线动能 > 1),0,K线动能0.6,2,0),colorlired; STICKLINE((K线动能 > 1),0,K线动能0.5,2,0),colorlired;
STICKLINE((K线动能 > 1),0,K线动能0.4,2,0),colorlired; STICKLINE((K线动能 > 1),0,K线动能0.3,2,0),colorlired;
STICKLINE((K线动能 > 1),0,K线动能0.2,2,0),colorlired; STICKLINE((K线动能 > 1),0,K线动能0.1,2,0),colorlired;
STICKLINE((K线动能 < 1),0,K线动能,2,0),COLOR00FF00; STICKLINE((K线动能 < 1),0,K线动能0.9,2,0),COLOR00FF00; STICKLINE((K线动能 < 1),0,K线动能0.8,2,0),COLOR00FF00; STICKLINE((K线动能 < 1),0,K线动能0.7,2,0),COLORFF9900; STICKLINE((K线动能 < 1),0,K线动能0.6,2,0),COLORFF9900; STICKLINE((K线动能 < 1),0,K线动能0.5,2,0),COLORFF9900; STICKLINE((K线动能 < 1),0,K线动能0.4,2,0),COLORFF9900; STICKLINE((K线动能 < 1),0,K线动能0.3,2,0),COLORFF9900; STICKLINE((K线动能 < 1),0,K线动能0.2,2,0),COLORFF9900; STICKLINE((K线动能 < 1),0,K线动能0.1,2,0),COLORFF9900; M1:=(DCLOSE-CLOSE)50; M2:EMA(EMA(M1,2),5),colorblue,LINETHICK1; IF(M2>0,M2,DRAWNULL),colorred,LINETHICK2;
IF(M2<0,M2,DRAWNULL),colorwhite,LINETHICK1; STICKLINE(CROSS(M2,0),0,25,2,0),colormagenta; STICKLINE(CROSS(0,M2),0,-25,2,0),colorblue,; VC:=(2CLOSE+HIGH+LOW)/4; K:=SLOPE(WMA(VC,3),11)5+VC,COLOR00FFFF; D:=WMA(K,3),colorblue; J:=2.8K-1.8D,coloryellow,LINETHICK1; K3:=EMA(K,5); D3:=EMA(D,5); KD:=(K3+D3)/2; KDCD:=EMA(KD,5)-EMA(KD,13); KDCD3:EMA(KDCD,5)*50,colorgreen,LINETHICK1; IF(KDCD3>REF(KDCD3,3),KDCD3,DRAWNULL),colorred,LINETHICK1;
IF(KDCD3<REF(KDCD3,3),KDCD3,DRAWNULL),colorred;
DRAWTEXT(CROSS(M2,KDCD3),KDCD3=M2,’B’😉,COLOR00FFFF;
DRAWTEXT(CROSS(KDCD3,M2),KDCD3=M2,’今S’😉,COLOR00FF00;
DRAWBAND(M2,RGB(180,0,0),KDCD3,RGB(0,158,0));

原创文章,作者:股神,如若转载,请注明出处:https://www.gupiaoxuexi.com/post/114792

本站所有文章、数据仅供投资者参考,不构成投资建议,风险自负。

发表评论

登录后才能评论