通达信优化改进版MACD指标公式

0,COLORLIGRAY;
DIF:EMA(CLOSE,12)-EMA(CLOSE,26),COLORWHITE,LINETHICK1;
DEA:EMA(DIF,9),COLOR00FFFF,LINETHICK1;
MACD:2(DIF-DEA),COLORFF00FF,COLORSTICK; 主线:EMA(DIF-MA(REF(DIF,1),1),1)1.862,COLORGREEN,LINETHICK1;
量线:EMA(DEA-MA(REF(DEA,1),1),1)*1.862,COLORFFFF1A,LINETHICK1;
IF(主线>=量线 AND 主线>-0.0099,主线,DRAWNULL),COLORRED,LINETHICK2;
IF(主线>-0.0099 AND DIF>REF(DIF,1),主线,DRAWNULL),COLORRED,LINETHICK2;
IF(主线>=量线 AND 量线>REF(量线,1) AND 量线>-0.0099,量线,DRAWNULL),COLORLIMAGENTA,LINETHICK2;
IF(量线>-0.0099 AND DIF>DEA AND DIF>-0.0099,量线,DRAWNULL),COLORLIMAGENTA,LINETHICK2;

原创文章,作者:股神,如若转载,请注明出处:https://www.gupiaoxuexi.com/post/114796

本站所有文章、数据仅供投资者参考,不构成投资建议,风险自负。

发表评论

登录后才能评论