通达信主升浪波段买入主图指标公式

N:=3;
短趋势线 :MA(CLOSE,13),COLORRED,LINETHICK3;
中线 :=MA(CLOSE,33),LINETHICK1;
中趋势线 :MA(CLOSE,55),LINETHICK1,COLORGRAY;
年线 :MA(CLOSE,250),LINETHICK1,COLORLIGRAY,POINTDOT;
涨 :IF( 短趋势线 > REF( 短趋势线 ,1), 短趋势线 ,DRAWNULL),COLORRED,LINETHICK3;
平 :=IF( 短趋势线 = REF( 短趋势线 ,1), 短趋势线 ,DRAWNULL),COLOR00FFFF,LINETHICK3;
跌 :IF( 短趋势线 < REF( 短趋势线 ,1), 短趋势线 ,DRAWNULL),COLORGREEN,LINETHICK3; 上极限 :=((C-REF(MA(CLOSE,20),1))/20+ 短趋势线 )1.20; DRAWTEXT(CROSS(CLOSE, 上极限 ),H1.02,’ 减仓’ ),COLORGREEN; DRAWTEXT(CROSS(CLOSE,MA(C,13)) AND 短趋势线 < REF( 短趋势线 ,1) AND 短趋势线 < 中趋势线 ,H1.02, ‘减仓’ ),COLORGREEN; DRAWTEXT(CROSS( 短趋势线 ,C) AND INDEXC> MA(INDEXC,13) AND 短趋势线 > REF( 短趋势线 ,1) AND V< REF(V,1) AND 短趋势线 > 中趋势线 ,L0.97,’ 买入’ ),COLORRED; STICKLINE(CROSS( 短趋势线 ,C) AND 短趋势线 > REF( 短趋势线 ,1) AND V< REF(V,1) AND 短趋势线 > 中趋势线 ,L,L0.99,2,0),COLORYELLOW; VAR1:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)100)/3;
DRAWTEXT(VAR1> 9 AND V< REF(V,1) AND FILTER(VAR1< REF(VAR1,1),5),H1.02,’ 洗盘’ ),COLORYELLOW; DRAWTEXT(VAR1> 9 AND V> REF(V,1) AND FILTER(VAR1< REF(VAR1,1),5),H1.02, ‘减仓’ ),COLORGREEN; DRAWTEXT(VAR1> 20 AND FILTER(VAR1< REF(VAR1,1),5),H1.06, ‘卖出’ ),COLORYELLOW; VAR2:=HHV(VAR1> 20,10); DRAWTEXT(FILTER(VAR1< -9 AND VAR1> REF(VAR1,1),18) AND V> REF(V,1),L0.98, ‘反弹’ ),COLORRED; DRAWTEXT(VAR1< -20 AND FILTER(VAR1> REF(VAR1,1),5),L0.95, ‘抄底’ ),COLORYELLOW; DRAWTEXT(VAR2 AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2STD(CLOSE,20)),H*1.1, ‘危险’ ),COLORYELLOW;
VAR12:=(HIGH – LOW);
VAR3:=ABS((OPEN – CLOSE));
VAR4:=(HIGH – IF((CLOSE > OPEN),CLOSE,OPEN));
VAR5:=(IF((CLOSE > OPEN),OPEN,CLOSE) – LOW);
VAR6:=((VAR3 / VAR12) * VOL);
VAR7:=((VAR4 / VAR12) * VOL);
VAR8:=((VAR5 / VAR12) * VOL);
VARB:=(((MA(CLOSE,5) > MA(CLOSE,10)) AND (MA(CLOSE,10) > MA(CLOSE,30))) AND (MA(CLOSE,30) > MA(CLOSE,60)));
VARA:=(((CLOSE – MA(CLOSE,5)) / MA(CLOSE,5)) * 100);
DRAWTEXT((((((VAR6 > (MA(VOL,5) * 2)) AND 短趋势线 >REF( 短趋势线 ,1) AND (VAR6 >= VAR7)) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)) OR ((VOL > (MA(VOL,5) * 3)) AND VARB)) ,L*0.98, ‘主力介入’ ),COLORMAGENTA;

原创文章,作者:股神,如若转载,请注明出处:https://www.gupiaoxuexi.com/post/115027

本站所有文章、数据仅供投资者参考,不构成投资建议,风险自负。

发表评论

登录后才能评论