通达信抄底彩虹指标公式

N:=27;
盘:=CAPITAL/1000000;
益:=FINANCE(33);
资:=FINANCE(34);
换手:=VOL/CAPITAL;
长阳:=(WINNER(C)-WINNER(O))>=0.15 AND 换手<=0.04; {缩量长阳:IF(长阳,(WINNER(C)-WINNER(O))100,0),STICK,COLOR6EA4FF,LINETHICK2;} VAR1:=(C-REF(C,1))/REF(C,1); VAR2:=(INDEXC-REF(INDEXC,1))/REF(INDEXC,1); 个股:=EMA(SUM(VAR1,20),5); 大盘:=EMA(SUM(VAR2,20),5); 领涨:=(个股-大盘)>=0; VAR3:=(C-LLV(L,125))/(HHV(H,125)-LLV(L,125))100; VAR4:=SMA(VAR3,72,1); VAR5:=SMA(VAR4,34,1); 中线趋势:=3VAR4-2VAR5; 中线趋势升:=(中线趋势-REF(中线趋势,1))>=0;
均五升:=(MA(C,5)-REF(MA(C,5),1))>=0;
均十升:=(MA(C,10)-REF(MA(C,10),1))>=0;
STICKLINE(均五升 AND 均十升 AND 中线趋势升,0+0.5,0-0.5,6,1),COLORFFFF00,LINETHICK4;
领涨大盘:IF(均五升 AND 均十升 AND 中线趋势升 AND 领涨,4,0),COLORFF99FF;
VAR6:=(2C+H+L)/4; VAR7:=LLV(L,N); VAR8:=HHV(H,N); 抄底:=EMA((VAR6-VAR7)/(VAR8-VAR7)100,13)-50;
金山:=EMA(0.618REF(抄底,1)+0.382抄底,3);
STICKLINE(抄底>金山 AND 抄底>=REF(抄底,1),抄底+5,金山-1,1.5,0),COLORRED,LINETHICK2;
STICKLINE(抄底>金山 AND 抄底=金山,金山,金山,1.5,0),COLORYELLOW,LINETHICK2;
STICKLINE(抄底<金山,金山+0.5,金山-0.5,1.5,0),COLORFFFF00,LINETHICK2; {STICKLINE(领涨大盘=4,抄底+6,金山-1,1.5,0),COLORFF99FF;} 强弱界:0,COLORFFFF00; STICKLINE(抄底>=金山 AND 均五升 AND 均十升 AND 中线趋势升 ,金山-3,金山-7,2,0),COLOR64A0E6 ;
运动员:=IF(抄底>=金山 AND 均五升 AND 均十升 AND 中线趋势升 AND 金山<0,1,0); 启动点:IF(运动员=1 AND COUNT(运动员=1,5)=1,8,0),COLORFF9999,LINETHICK1; {DRAWTEXT(启动点=8,金山,’启动点’😉,COLORWHITE;} BIAS1:=(C-MA(C,6))/MA(C,6)100; BIAS2:=(C-MA(C,12))/MA(C,12)100; BIAS3:=(C-MA(C,24))/MA(C,24)100; BIAS:=(BIAS1+2BIAS2+3*BIAS3)/6; 乖离:=MA(BIAS,3); 准备:STICKLINE(乖离<-6 AND 乖离>=-12,-6,0,6,1 ),{COLOR33FFCC}COLORYELLOW;
抄底一:IF(乖离<-12 AND 乖离>=-18,-12,0),{COLOR33CCCC}COLORMAGENTA,STICK;
STICKLINE(乖离<-12 AND 乖离>=-18,-12,0,2,0) ,{COLOR33CCCC}COLORMAGENTA;
抄底二:IF(乖离<-18,-18,0),{COLOR3399CC}COLORYELLOW,STICK; STICKLINE(乖离<-18,-18,0,2,0) ,{COLOR3399CC}COLORYELLOW; 必抄底:IF(启动点=8 AND COUNT(乖离<-12,10)>=1,10,0),LINETHICK0,COLORRED;
STICKLINE(必抄底=10,10,0,10,1),COLORRED;

原创文章,作者:股神,如若转载,请注明出处:https://www.gupiaoxuexi.com/post/117213

本站所有文章、数据仅供投资者参考,不构成投资建议,风险自负。

发表评论

登录后才能评论