通达信牛熊分道主图指标公式

价量:=3SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27) -LLV(LOW,27))100,5,1)-2SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))100,5,1),3,1);
主力活跃力度:=(((价量-LLV(价量,27))/(HHV(价量,27)-LLV(价量,27)))(4))(25);
快线:=(((价量-LLV(价量,9))/(HHV(价量,9)-LLV(价量,9)))(4))(25);
RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))100; K1:=SMA(RSV,3,1); D1:=SMA(K1,3,1); KK:=INTPART(K1); DD:=INTPART(D1); TFXXS:=KK+DD; TGLXS:=(TFXXS-REF(TFXXS,1)); 主力筹码:=EMA(WINNER(CLOSE)70,3);
散户筹码:=EMA((WINNER(CLOSE1.1)-WINNER(CLOSE0.9))80,3); 金叉疯牛:=EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2); 界:=MA(CLOSE,27); 持股时段:IF((金叉疯牛>界)AND(散户筹码<主力筹码)AND ((主力活跃力度>50)OR(主力活跃力度>REF(主力活跃力度,1))),-40,0),COLORRED,NODRAW; ZLCM:=EMA(WINNER(CLOSE)70,3);
{//主力筹码估算}
SHCM:=EMA((WINNER(CLOSE1.1)-WINNER(CLOSE0.9))80,3); {//小筹码估算} ZSHTL:=SHCM/(ZLCM+SHCM)100;
{//小股民套牢筹码比率}
ZZLKP:=ZLCM/(ZLCM+SHCM)100; {//主力控盘筹码比} ZCMZL:=MA(ZLCM+SHCM,13); {//市场筹码总量} ZZNTS:=BArslAst(ZSHTL<90 AND REF(ZSHTL,1)>90); {//走牛天数} ZSHJJ:=EMA(ZSHTL,89); {//小股民警戒} ZZLJJ:=EMA(ZZLKP,89); {//主力警戒} ZJLRQD:=INTPART(ZZLKP-ZZLJJ); {//资金流入强度} BB:=MA(C,1); 持币阶段:SMA(SMA(SMA(BB,2,1),2,1),2,1); 主升持股波段:=HHV(MA(持币阶段,1),13); SH8:=EMA(ZSHTL,8); DKB:=IF(ZZLKP-REF(ZZLKP,1)>ZSHTL-REF(ZSHTL,1),1,0); 牛股出现预警:=WINNER(C/1.10)100,COLOR00FFFF,NODRAW;
主力赢利25持仓:=WINNER(C/1.25)100,COLORFF00FF,NODRAW; 散户套牢筹码:=散户筹码/(主力筹码+散户筹码)100;
主升浪波段:=主力筹码/(主力筹码+散户筹码)100,COLORFF6100,NODRAW; 主力主导行情:=EMA(主升浪波段,55),NODRAW,COLORFF00FF; M:=60; N:=30; SHX:=100(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60)) COLORGRAY;
庄家主力线:=50-SMA(SMA(SMA(SHX,2,1),2,1),2,1)/2,COLOR00FFFF,LINETHICK2;
散户持股线:=50-HHV(MA(庄家主力线,1),13)/2,COLORFF00FF,LINETHICK4;
跌幅:=(REF(C,1)-C)/REF(C,1)100; 涨幅:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)100,POINTDOT,COLOR009900,LINETHICK0;
ER:=V/FINANCE(7)100; A0:=TMA(ER,(1-ER),1); MAXcyc:=DMA((C+O)/2,ER/TMA(ER,(1-ER),1)); T1:=BARSLAST(C>MAXCYCPOW(1.1,0.9));
T2:=BARSLAST(CPOW(1.1,-0.9)); T3:=crOSS(T1,T2) OR CROSS(T2,T1) OR BARSSINCE(T1+1)=0 OR BARSSINCE(T2+1)=0 OR BARSCOUNT(C)=0; T4:=REF(MAXCYC,BARSLAST(T3)); HZ:=HHV((H+L)/2,120); AA:=(2C+H+L)/4; VAR1:=IF(DATE=10301201,0,1); VAR2:=EMA(SLOPE(CLOSE,21)20+CLOSE,55); VAR3:=EMA(CLOSE,3); VAR4:=(2CLOSE+LOW+HIGH)/4VAR1; VAR5:=VAR2-VAR3; VAR6:=CLOSEvol; VAR7:=EMA((EMA(VAR6,3)/EMA(VOL,3)+EMA(VAR6,6)/EMA(VOL,6)+EMA(VAR6,12)/EMA(VOL,12)+EMA(VAR6,24)/EMA(VOL,24))/4,13); VAR8:=(EMA(CLOSE,5)7+EMA(CLOSE,10)3)/10; VAR9:=(CLOSE+OPEN)/2; MA5:=MA(CLOSE,5); VAR11:=3SMA((C-LLV(L,480))/(HHV(H,480)-LLV(L,480))100,5,1) -2SMA(SMA((C-LLV(L,480))/(HHV(H,480)-LLV(L,480))100,180,1),15,1); 超级主升:=EMA(VAR11,5); 主升1:=超级主升-100; D8:=EMA(C,5); D2:=(EMA(C,1)+EMA(C,5)+EMA(C,10)+EMA(C,15)+EMA(C,20)+EMA(C,25)+EMA(C,30)+EMA(C,35)+EMA(C,40)+EMA(C,45)+ EMA(C,50)+EMA(C,55)+EMA(C,60)+EMA(C,65)+EMA(C,70)+EMA(C,75)+EMA(C,80)+EMA(C,85)+EMA(C,90)+EMA(C,95)+ EMA(C,100)+EMA(C,105)+EMA(C,110)+EMA(C,115)+EMA(C,120)+EMA(C,125)+EMA(C,130)+EMA(C,135)+EMA(C,140)+EMA(C,150))/30; dde:=(D8/D2)100; 主升2:=DDE-110; A:=(H+L+2C)/4; A1:=(A-REF(A,3))/3+A; J:=EMA(HHV(A1,20),60),LINETHICK3; CB5:=EMA(COST(80),30),CIRCLEDOT; HMX:=EMA(1.4EMA(FORCAST(A1,20),40),20),LINETHICK2; 金牛线:=(J+CB5+HMX)/3,LINETHICK2; MA20:=MA(C,20); UP:=EMA(EMA(C1.38,50),50),DOTLINE,COLOR0000FF; 白色:=SMA(HIGH,21,2)1.05; 黄色:=SMA(LOW,21,2)0.95; 中线:=(白色+黄色)/2; UP1:=中线+2STD(中线,20); UP2:=REF(UP1,0); CC:=Abs((2CLOSE+HIGH+LOW)/4-MA(A1,20))/MA(A1,20); DT:=DMA(CLOSE,CC); 通道3:=(1+9/100)DT; 通道4:=(1-7/100)DT; 界限:=(REF((金牛线+UP+EMA(UP1¨C25C1.04)/2; AHC1:=H¨C26CAHC24; C下X:=AHC24¨C27CAHC22; 下X:=AHC22¨C28CAHC23; D下X:=AHC23¨C29C1.05; 主升3:=(MA5¨C30C100; cbx80:=MA(COST(80),20); 主升4:=(MA5/CBX80-1)¨C31C0.5; 主升5:=(FT/FT1-1)¨C32C1.14,55),20); 主升6:=(MA5/P-1)¨C33C1.62)/2; 主升7:=(MA5/金K线-1)¨C34C2+H+L)/4¨C35C(V2-V3)¨C36C1.15,15),COLORRED,LINETHICK1; 黄线:=(EMA(VAR9,3)+EMA(VAR9,6)+EMA(VAR9,12)+EMA(VAR9,24))/4,COLORYELLOW,LINETHICK1; HH:=(20¨C37CREF(H,1)+18¨C38CREF(H,3)+16¨C39CREF(H,5)+14¨C40CREF(H,7)+12¨C41CREF(H,9)+10¨C42CREF(H,11)+8¨C43CREF(H,13)+6¨C44CREF(H,15)+4¨C45CREF(H,17)+2¨C46CL+19¨C47CREF(L,2)+17¨C48CREF(L,4)+15¨C49CREF(L,6) +13¨C50CREF(L,8)+11¨C51CREF(L,10)+9¨C52CREF(L,12) +7¨C53CREF(L,14)+5¨C54CREF(L,16)+3¨C55CREF(L,18)+ REF(L,20))/210,COLORBLUE,LINETHICK1; VAR80:=3¨C56C100,5,1)-2¨C57C100,180,1),15,1); 疯牛潜力股:=EMA(VAR80,5), NODRAW,COLOR6600FF; 牛熊分道:EMA(HH,90),COLORYELLOW,LINETHICK2; 下:=牛熊分道-((C-牛熊分道)¨C58C1.68,LINETHICK3,COLORRED; 下轨:=MA(下,14),COLORGREEN,LINETHICK2; IF(持股时段<-28 AND 上轨>=下轨 AND 牛熊分道>=下轨 AND 疯牛潜力股>REF(疯牛潜力股,1),下轨,DRAWNULL),COLORFF0080,LINETHICK6;
IF(持股时段<-28 AND 疯牛潜力股>50 AND BARSCOUNT(C)>250 AND 上轨>=下轨 AND 牛熊分道>=下轨 AND 疯牛潜力股>=REF(疯牛潜力股,1),下轨,DRAWNULL),COLORFF0080,LINETHICK6;
IF(疯牛潜力股>50 AND BARSCOUNT(C)>250 AND 上轨>=下轨 AND 牛熊分道>=下轨 AND 疯牛潜力股<=REF(疯牛潜力股,1),下轨,DRAWNULL),COLORGREEN,LINETHICK6; IF(上轨>=下轨 AND 下轨>REF(下轨,1),下轨,DRAWNULL),COLORGREEN,LINETHICK6;
IF(持股时段<-28 AND BARSCOUNT(C)<250 AND 上轨>=下轨 AND 牛熊分道>=下轨 AND 疯牛潜力股>=REF(疯牛潜力股,1),下轨,DRAWNULL),COLORFF0080,LINETHICK6;
IF(持股时段=0 AND BARSCOUNT(C)<250 AND 上轨>=下轨 AND 牛熊分道>=下轨 AND 疯牛潜力股>=REF(疯牛潜力股,1),下轨,DRAWNULL),COLORFF00FF,LINETHICK6;
IF(疯牛潜力股>50 AND 上轨>=下轨 AND 疯牛潜力股>REF(疯牛潜力股,1) AND 牛熊分道>=下轨,上轨,DRAWNULL),COLORFF00FF,LINETHICK4;
IF(疯牛潜力股>50 AND 上轨>=下轨 AND 疯牛潜力股>REF(疯牛潜力股,1),上轨,DRAWNULL),COLORFF00FF,LINETHICK4;
IF(COUNT(C>上轨,5)>=2 AND 上轨>=牛熊分道 AND 疯牛潜力股>REF(疯牛潜力股,1) AND 涨幅>0.5,上轨,DRAWNULL),COLOR0000FF,LINETHICK4;
不参与阶段:IF(上轨<下轨,上轨,上轨),COLORGREEN,LINETHICK2; 分道关注:IF(上轨>=下轨 AND 牛熊分道<下轨 AND 下轨=下轨 AND 牛熊分道<下轨 AND 下轨50 AND 上轨>=下轨 AND 牛熊分道>=下轨 AND 疯牛潜力股>REF(疯牛潜力股,1),下轨,DRAWNULL),COLORFF0080,LINETHICK2;
IF(持股时段<-28 AND 上轨>=下轨 AND 牛熊分道>=下轨 AND 疯牛潜力股>REF(疯牛潜力股,1),下轨,DRAWNULL),COLORFF0080,LINETHICK2;
IF(持股时段<-28 AND 疯牛潜力股>50 AND BARSCOUNT(C)>250 AND 上轨>=下轨 AND 牛熊分道>=下轨 AND 疯牛潜力股>=REF(疯牛潜力股,1),下轨,DRAWNULL),COLORFF0080,LINETHICK2;
IF(疯牛潜力股>50 AND BARSCOUNT(C)>250 AND 上轨>=下轨 AND 牛熊分道>=下轨 AND 疯牛潜力股<=REF(疯牛潜力股,1),下轨,DRAWNULL),COLORGREEN,LINETHICK2; IF(上轨>=下轨 AND 下轨>REF(下轨,1),下轨,DRAWNULL),COLORGREEN,LINETHICK2;
IF(持股时段<-28 AND BARSCOUNT(C)<250 AND 上轨>=下轨 AND 牛熊分道>=下轨 AND 疯牛潜力股>=REF(疯牛潜力股,1),下轨,DRAWNULL),COLORFF0080,LINETHICK2;
IF(疯牛潜力股>50 AND 上轨>=下轨 AND 疯牛潜力股>REF(疯牛潜力股,1) AND 牛熊分道>=下轨,上轨,DRAWNULL),COLORFF00FF,LINETHICK2;
IF(疯牛潜力股>50 AND 上轨>=下轨 AND 疯牛潜力股>REF(疯牛潜力股,1),上轨,DRAWNULL),COLORFF00FF,LINETHICK2;
超级疯牛分界:IF(持股时段<-28 AND 疯牛潜力股>50 AND 上轨>=下轨 AND 疯牛潜力股>REF(疯牛潜力股,1),上轨,DRAWNULL),COLORRED,LINETHICK2;
IF(COUNT(C>上轨,5)>=2 AND 上轨>=牛熊分道 AND 疯牛潜力股>REF(疯牛潜力股,1) AND 涨幅>0.5,上轨,DRAWNULL),COLORRED,LINETHICK2;
开口选股:=BARSLASTCOUNT(上轨>下轨)=1,NODRAW;
DRAWICON(开口选股,MIN(下轨,上轨)1.08,26); DRAWTEXT(开口选股,LOW,71),COLORYELLOW; DRAWTEXT(开口选股,上轨1.13,’开始关注’),COLORRED;
变盘加速上扬:=CROSS(牛熊分道,下轨);
DRAWICON(变盘加速上扬,LOW*0.9,25);

原创文章,作者:股神,如若转载,请注明出处:https://www.gupiaoxuexi.com/post/121366.html

本站所有文章、数据仅供投资者参考,不构成投资建议,风险自负。

(0)
打赏 微信扫一扫 微信扫一扫 支付宝扫一扫 支付宝扫一扫

相关推荐

  • 通达信淘金王指标公式

    通达信淘金王指标公式 小顶:80,COLORFFA500;大顶:100,COLORBLUE;VAR1:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*80;VAR2:=SMA(VAR1,10,1);慢速:SMA(VAR2,5,1),COLORRED;RSV:= ((HHV(HIGH,9)-CLOSE)/(HHV…

    股票公式 2018年11月5日
    2940
  • 通达信多空买卖线指标公式

    通达信多空买卖线指标公式 DIF:=EMA(C,7)-EMA(C,21);趋势:=EMA((0.668*REF(DIF,1)+0.333*DIF),1);做多:IF(DIF>=趋势,DIF,趋势)*3,LINETHICK2,COLORRED;做空:IF(趋势-DIF,趋势,DIF)*3,COLORLIGREEN,LINETHICK2;快线:(C-LLV…

    股票公式 2018年9月8日
    8070
  • 通达信多空强弱主图指标公式

    所属地区:DRAWTEXT_FIX(1,0,0.05,0,1948),COLORCYAN;DRAWTEXT_FIX(1,0.05,0.05,0,DYBLOCK),COLORCYAN;所属行业:DRAWTEXT_FIX(1,0,0.1,0,1949),COLORCYAN;DRAWTEXT_FIX(1,0.05,0.1,0,HYBLOCK),COLORCYAN;…

    股票公式 2022年1月26日
    100
  • 通达信黑马红柱抄底副图/选股指标公式

    通达信黑马红柱抄底副图/选股指标公式 黑马红柱指标:是我作为抄底信号的参考指标之一,抄底信号就是需要耐心等,只要没破位就坚决握住。 {黑马红柱幅图} 昨收:=REF(CLOSE,1);趋势:SMA(MAX(CLOSE-昨收,0),8,1)/SMA(ABS(CLOSE-昨收),8,1)*100,COLOR0080FF,LINETHICK2;下:20,COLOR…

    股票公式 2019年7月12日
    2820
  • 通达信绝佳买入指标公式

    通达信绝佳买入指标公式 A1:=ABS((EMA(CLOSE, 5) – EMA(CLOSE, 10))) * 628;A2:=A1 / CLOSE;超短线1:IF((A1<A2),1,0),LINETHICK2,COLORRED;A3:=REF(CLOSE,1);A4:=SMA(MAX((CLOSE – A3),0), 8, …

    股票公式 2018年9月14日
    3450

发表评论

登录后才能评论