通达信主力趋势买入指标公式

DRAWGBK(C>0, RGB(0,10,10),RGB(48,0,0),0,’11’,0);
AA1:=(CLOSE-LLV(LOW,43))/(HHV(HIGH,43)-LLV(LOW,43))100; AA2:=SMA(AA1,2,1); 主力趋势:SMA(AA2,2,1),LINETHICK3,COLORFFCC66; 压力位:100,COLORRED; 支撑位:0,COLORGREEN; 中界:50,COLORFFAA00; DRAWTEXT(ISLAstBAR,中界,’中界’),COLORFFAA00; A:92,COLOR3399FF; B:8,COLOR3399FF; 买:STICKLINE(crOSS(主力趋势,4),0,50,0,0),COLORRED; DRAWICON(CROSS(主力趋势,4),58,1); DRAWICON(CROSS(主力趋势,4),70,26); 卖:STICKLINE(CROSS(96,主力趋势),100,50,0,0),COLORGREEN; DRAWICON(CROSS(96,主力趋势),40,2); DRAWICON(CROSS(96,主力趋势),30,15); IF(主力趋势>REF(主力趋势,1),主力趋势,DRAWNULL),COLORMAGENTA,LINETHICK3; DIF:=EMA(CLOSE,12)-EMA(CLOSE,26); DEA:=EMA(DIF,9); macd:=2(DIF-DEA);
MacD空头A:=MACD>0 AND MACD=REF(MACD,2);
均线空头A:=C=REF(C,2) AND REF(C,2)>=REF(C,3);
趋势空头A:=主力趋势>89 AND (主力趋势<=REF(主力趋势,1)); 空头买点:=趋势空头A AND MACD空头A AND 均线空头A; MACD多头B:=MACD<0 AND MACD>REF(MACD,1) AND REF(MACD,1)<=REF(MACD,2); 均线多头B:=C>=REF(C,1) AND REF(C ,1)<=REF(C,2) AND REF(C,2)<=REF(C,3); 趋势多头B:=主力趋势<11 AND (主力趋势>=REF(主力趋势,1));
多头买点:=趋势多头B AND MACD多头B AND 均线多头B;
DRAWICON(多头买点,30,1);
DRAWICON(多头买点,40,7);
STICKLINE(多头买点,0,20,0.01,0),COLORRED;
DRAWICON(空头买点,70,2);
DRAWICON(空头买点,60,8);
STICKLINE(空头买点,100,80,0.01,0),COLORGREEN;

原创文章,作者:股神,如若转载,请注明出处:https://www.gupiaoxuexi.com/post/121378.html

本站所有文章、数据仅供投资者参考,不构成投资建议,风险自负。

(0)
打赏 微信扫一扫 微信扫一扫 支付宝扫一扫 支付宝扫一扫

相关推荐

发表评论

登录后才能评论