通达信资金动态柱指标公式

通达信资金动态柱指标公式

{使用说明:向上实芯柱体指明进出量(买量+卖量)为流进量之大小;向上空心黄柱指示超大和大单超出中和小单之差。向下实芯柱体指明进出量(买量+卖量)为流出量之大小;向下空心白柱指示中和小单超出超大和大单之差。}

N:=1;
AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买量:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),LINETHICK0,COLORRED;
卖量:=IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-AA*(HIGH-LOW),0-VOL/2)),LINETHICK0,COLORGREEN;
进出量:=买量+卖量,COLOR00FFFF;STICKLINE(进出量<0,0,进出量,1,0),COLORFF6600;
STICKLINE(进出量<0,0,进出量,3.0,0),COLORBLUE;
STICKLINE(进出量<0,0,进出量,2.0,0),COLORLIBLUE;
STICKLINE(进出量<0,0,进出量,1.0,0),COLORCYAN;
STICKLINE(进出量<0,0,进出量,0.1,0),COLORWHITE;
STICKLINE(进出量>0,0,进出量,3.0,0),COLOR000099;
STICKLINE(进出量>0,0,进出量,2.0,0),COLOR0000CC;
STICKLINE(进出量>0,0,进出量,1.0,0),COLOR0000FF;
STICKLINE(进出量>0,0,进出量,0.1,0),COLORCC66FF;
QJ0:=(HIGH+LOW+CLOSE)/3;
QJ1:=IF(HIGH=LOW,1,HIGH-MAX(OPEN,CLOSE));
QJ2:=IF(HIGH=LOW,1,MAX(CLOSE,OPEN)-QJ0);
QJ3:=IF(HIGH=LOW,1,MIN(OPEN,CLOSE)-LOW);
QJ4:=IF(HIGH=LOW,1,QJ0-MIN(CLOSE,OPEN));
QJ5:=VOL/(IF(HIGH=LOW,4,HIGH-LOW));
QJ6:=”MACD.DIF”>”MACD.DEA” AND “MACD.DEA”<0;
QJ7:=”KDJ.K”>”KDJ.D” AND “KDJ.D”<30;
QJ8:=”MACD.DIF”<“MACD.DEA”;
QJ9:=”KDJ.K”<“KDJ.D” AND “KDJ.K”>80;
超大:QJ4*QJ5,NODRAW;
大单:QJ3*QJ5,NODRAW;
中单:QJ1*QJ5,NODRAW;
小单:QJ2*QJ5,NODRAW;
W1:=SUM(大单,N)+SUM(超大,N);
W2:=SUM(小单,N)+SUM(中单,N);
A:=W1-W2;{超大和大,与中和小之差}
A0:=IF(A>0,A,0);
B0:=IF(A<0,A,0);
STICKLINE(A0,0,A0,1,1),COLORYELLOW;{COLOR000044}
STICKLINE(B0,0,B0,1,1),COLORWHITE;
主力持仓:EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3),COLORFF00FF;
主力筹码集中度:WINNER(C)*100,COLORRED;

原创文章,作者:股神,如若转载,请注明出处:https://www.gupiaoxuexi.com/post/32222

本站所有文章、数据仅供投资者参考,不构成投资建议,风险自负。

发表评论

登录后才能评论