通达信天神捉妖多周期共振副图指标公式

通达信天神捉妖多周期共振副图指标公式

{机构增仓}
JA1:=(VOL/C)/2;
A2YT:=SUM(IF(JA1>100ANDREF(CLOSE,1)>REF(CLOSE,2),JA1,0),0);
A3Y:=SUM(IF(JA1>100ANDREF(CLOSE,1)REF(CLOSE,2),JA1,0),0);
A5Y:=SUM(IF(JA1<100ANDREF(CLOSE,1)100;机卖:=(A3Y/A6Y)100;主力差:=机买-机卖;机构加仓:=(主力差>REF(主力差,1)+1.2)AND机买>机卖;
XXBB:=EMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))4,5)100;
追拉升:=REF(XXBB,1)>50ANDXXBB-REF(XXBB,1)>40;
机构追买:=机构加仓AND追拉升;

{何氏妖股}
月DIF:=”MACD.DIF#MONTH”;
月DEA:=”MACD.DEA#MONTH”;
周DIF:=”MACD.DIF#WEEK”;
周DEA:=”MACD.DEA#WEEK”;
日DIF:=”MACD.DIF”;
日DEA:=”MACD.DEA”;
日金叉:=CROSS(日DIF,日DEA);
周金叉:=CROSS(周DIF,周DEA);
月金叉:=CROSS(月DIF,月DEA);

WIW:=((日DIF>日DEAAND周DIF>周DEAAND月金叉)OR(周DIF>周DEAAND月DIF>月DEAAND日金叉)OR(日DIF>日DEAAND月DIF>月DEAAND周金叉)OR(日金叉AND周金叉AND月金叉)OR(日DIF>日DEAAND周DIF>周DEAAND月DIF>月DEA));

月K:=”KDJ.K#MONTH”;
月D:=”KDJ.D#MONTH”;
周K:=”KDJ.K#WEEK”;
周D:=”KDJ.D#WEEK”;
日K:=”KD.K”;
日D:=”KD.D”;
日金叉1:=IF(CROSS(日K,日D),15,0);
周金叉1:=IF(CROSS(周K,周D),25,0);
月金叉1:=IF(CROSS(月K,月D),35,0);
日周月:=IF(日金叉1=15AND周金叉1=25AND月金叉1=35,1,0);
日周月赚:=日周月=1;
日周:=IF(日金叉1=15AND周金叉1=25,2,0);
日周赚:=日周=2;
周月:=IF(周金叉1=25OR月金叉1=35,4,0);
日月:=IF(日金叉1=15AND月金叉1=35,5,0);
日月赚:=日月=4;
周月赚:=周月=3;
S1:=日K>日D;S2:=周K>周D;S3:=月K>月D;

WHW:=((S1ANDS2AND周金叉1AND日金叉1)OR(S1ANDS2AND周金叉1AND月金叉1)OR(S1ANDS3AND周金叉1AND月金叉1)OR(日金叉1AND周金叉1AND月金叉1)OR(S2ANDS3AND周金叉1AND月金叉1)OR(日金叉1AND周金叉1ANDS2ANDS3)OR(S1ANDS3ANDS2)OR(日月赚AND日周月赚AND周月赚)OR(日月赚AND日周赚AND日周月赚)OR(日周赚AND日周月赚AND周月赚)OR(日月赚AND日周赚AND周月赚));

涨停1:=(H/REF(C,1)>1.099ANDC=H)OR(H/L>1.11ANDC/L>1.06);
Y1Y:=COUNT(WIW,18)>0ORCOUNT(WIW,48)>0ORWIW;
Y2Y:=COUNT(WHW,18)>0ORCOUNT(WHW,48)>0ORWHW;
Y3Y:=COUNT(机构加仓OR机构追买,18)>0ORCOUNT(机构加仓OR机构追买,48)>0OR(机构加仓OR机构追买);
A1T:=ABS(((3.48CLOSE+HIGH+LOW)/4-EMA(CLOSE,20))/EMA(CLOSE,20));A2T:=DMA(((2.15CLOSE+LOW+HIGH)/4),A1T);
金线王:=C>=EMA(A2T,144);
JXWS:=C>金线王#MIN30ORC>金线王#MIN60ORC>金线王;
天神捉妖:Y1YANDY2YANDY3YANDJXWS;

原创文章,作者:股神,如若转载,请注明出处:https://www.gupiaoxuexi.com/post/40779.html

本站所有文章、数据仅供投资者参考,不构成投资建议,风险自负。

发表评论

登录后才能评论